[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20140508070738.02b3051a9766a012c4c1a923@skynet.be>
Date: Thu, 8 May 2014 07:07:38 +0200
From: Fabian Frederick <fabf@...net.be>
To: Peter Zijlstra <peterz@...radead.org>
Cc: linux-kernel <linux-kernel@...r.kernel.org>,
akpm <akpm@...ux-foundation.org>
Subject: Re: [PATCH 2/2] kernel/stop_machine.c: remove false assignment to
static
On Wed, 7 May 2014 23:04:11 +0200
Peter Zijlstra <peterz@...radead.org> wrote:
> On Wed, May 07, 2014 at 10:46:56PM +0200, Fabian Frederick wrote:
> > This patch also fixes function prototype over 80 characters
>
> And does it wrong.. Also does it really matter to GCC that we init the
> bool? Surely it can see its 0 and put it in .bss anyway?
It's considered redundant but maintainer's choice is the priority :)
> > Cc: Peter Zijlstra <peterz@...radead.org>
> > Cc: Andrew Morton <akpm@...ux-foundation.org>
> > Signed-off-by: Fabian Frederick <fabf@...net.be>
> > ---
> > kernel/stop_machine.c | 5 +++--
> > 1 file changed, 3 insertions(+), 2 deletions(-)
> >
> > diff --git a/kernel/stop_machine.c b/kernel/stop_machine.c
> > index 695f0c6..8d29ee2 100644
> > --- a/kernel/stop_machine.c
> > +++ b/kernel/stop_machine.c
> > @@ -42,7 +42,7 @@ struct cpu_stopper {
> >
> > static DEFINE_PER_CPU(struct cpu_stopper, cpu_stopper);
> > static DEFINE_PER_CPU(struct task_struct *, cpu_stopper_task);
> > -static bool stop_machine_initialized = false;
> > +static bool stop_machine_initialized;
> >
> > /*
> > * Avoids a race between stop_two_cpus and global stop_cpus, where
> > @@ -241,7 +241,8 @@ static void irq_cpu_stop_queue_work(void *arg)
> > *
> > * returns when both are completed.
> > */
> > -int stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn, void *arg)
> > +int stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn,
> > + void *arg)
>
> Its only 84, so I didn't care to wrap it, its more readable this way,
> but if you want it split split it like:
>
> int
> stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn, void *arg)
>
> Or if you really have to split arguments to it in groups that make
> sense; like:
>
> int stop_two_cpus(unsigned int cpu1, unsigned int cpu2,
> cpu_stop_fn_t fn, void *arg)
>
> But really, these are two unrelated changes, and should therefore not be
> in a single patch.
Ok, thanks
Fabian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists