[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <alpine.LSU.2.11.1405101316470.1680@eggly.anvils>
Date: Sat, 10 May 2014 13:21:58 -0700 (PDT)
From: Hugh Dickins <hughd@...gle.com>
To: Jianyu Zhan <nasa4836@...il.com>
cc: akpm@...ux-foundation.org, riel@...hat.com, aarcange@...hat.com,
fabf@...net.be, zhangyanfei@...fujitsu.com, sasha.levin@...cle.com,
mgorman@...e.de, oleg@...hat.com, n-horiguchi@...jp.nec.com,
iamjoonsoo.kim@....com, kirill.shutemov@...ux.intel.com,
liwanp@...ux.vnet.ibm.com, gorcunov@...il.com, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/3] mm: rename mlocked_vma_newpage to
newpage_in_mlocked_vma
On Sat, 10 May 2014, Jianyu Zhan wrote:
> mlocked_vma_newpage is used to determine if a new page is mapped into
> a *mlocked* vma. It is poorly named, so rename it to newpage_in_mlocked_vma.
>
> Signed-off-by: Jianyu Zhan <nasa4836@...il.com>
newpage_in_mlocked_vma() is not as bad a name as mlocked_vma_newpage(),
but it's not especially good either (sounds like it answers a question,
not like it actually does something). Please just put it into its
sole caller and we don't need an obscuring name at all.
> ---
> mm/internal.h | 4 ++--
> mm/rmap.c | 4 ++--
> 2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/mm/internal.h b/mm/internal.h
> index 20abafb..35efd79 100644
> --- a/mm/internal.h
> +++ b/mm/internal.h
> @@ -183,7 +183,7 @@ static inline void munlock_vma_pages_all(struct vm_area_struct *vma)
> munlock_vma_pages_range(vma, vma->vm_start, vma->vm_end);
> }
>
> -extern int mlocked_vma_newpage(struct vm_area_struct *vma,
> +extern int newpage_in_mlocked_vma(struct vm_area_struct *vma,
> struct page *page);
This should have vanished in the previous patch.
> /*
> * must be called with vma's mmap_sem held for read or write, and page locked.
> @@ -227,7 +227,7 @@ extern unsigned long vma_address(struct page *page,
> struct vm_area_struct *vma);
> #endif
> #else /* !CONFIG_MMU */
> -static inline int mlocked_vma_newpage(struct vm_area_struct *v, struct page *p)
> +static inline int newpage_in_mlocked_vma(struct vm_area_struct *v, struct page *p)
Ditto.
Hugh
> {
> return 0;
> }
> diff --git a/mm/rmap.c b/mm/rmap.c
> index a9d02ef..9ff6915 100644
> --- a/mm/rmap.c
> +++ b/mm/rmap.c
> @@ -1014,7 +1014,7 @@ void do_page_add_anon_rmap(struct page *page,
> * pte is locked while calling page_add_new_anon_rmap(), so using a
> * light-weight version __mod_zone_page_state() would be OK.
> */
> -int mlocked_vma_newpage(struct vm_area_struct *vma,
> +int newpage_in_mlocked_vma(struct vm_area_struct *vma,
> struct page *page)
> {
> VM_BUG_ON_PAGE(PageLRU(page), page);
> @@ -1050,7 +1050,7 @@ void page_add_new_anon_rmap(struct page *page,
> __mod_zone_page_state(page_zone(page), NR_ANON_PAGES,
> hpage_nr_pages(page));
> __page_set_anon_rmap(page, vma, address, 1);
> - if (!mlocked_vma_newpage(vma, page)) {
> + if (!newpage_in_mlocked_vma(vma, page)) {
> SetPageActive(page);
> lru_cache_add(page);
> } else
> --
> 2.0.0-rc1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists