[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <537301FE.7080207@ti.com>
Date: Wed, 14 May 2014 11:11:18 +0530
From: George Cherian <george.cherian@...com>
To: <balbi@...com>
CC: <linux-kernel@...r.kernel.org>, <linux-omap@...r.kernel.org>,
<linux-usb@...r.kernel.org>, <gregkh@...uxfoundation.org>,
<rogerq@...com>, <kishon@...com>
Subject: Re: [PATCH 1/5] usb: dwc3: dwc3-omap: Add dwc3_omap_map_offset function
On 5/13/2014 9:32 PM, Felipe Balbi wrote:
> Hi,
>
> On Thu, May 08, 2014 at 03:03:03PM +0530, George Cherian wrote:
>> Calculate the wrapper register offsets in a seperate function.
>> Improve code readability, decrease the dwc3_probe() size.
>>
>> Signed-off-by: George Cherian <george.cherian@...com>
>> ---
>> drivers/usb/dwc3/dwc3-omap.c | 80 ++++++++++++++++++++++++--------------------
>> 1 file changed, 44 insertions(+), 36 deletions(-)
>>
>> diff --git a/drivers/usb/dwc3/dwc3-omap.c b/drivers/usb/dwc3/dwc3-omap.c
>> index 1160ff4..872f065 100644
>> --- a/drivers/usb/dwc3/dwc3-omap.c
>> +++ b/drivers/usb/dwc3/dwc3-omap.c
>> @@ -383,6 +383,49 @@ static int dwc3_omap_vbus_notifier(struct notifier_block *nb,
>> return NOTIFY_DONE;
>> }
>>
>> +static void dwc3_omap_map_offset(struct dwc3_omap *omap)
>> +{
>> + u32 reg;
>> + struct device_node *node = omap->dev->of_node;
>> + int x_major;
>> +
>> + reg = dwc3_omap_readl(omap->base, USBOTGSS_REVISION);
>> + omap->revision = reg;
>> + x_major = USBOTGSS_REVISION_XMAJOR(reg);
>> +
>> + /* Differentiate between OMAP5 and AM437x */
>> + switch (x_major) {
>> + case USBOTGSS_REVISION_XMAJOR1:
>> + case USBOTGSS_REVISION_XMAJOR2:
>> + omap->irq_eoi_offset = 0;
>> + omap->irq0_offset = 0;
>> + omap->irqmisc_offset = 0;
>> + omap->utmi_otg_offset = 0;
>> + omap->debug_offset = 0;
>> + break;
>> + default:
>> + /* Default to the latest revision */
>> + omap->irq_eoi_offset = USBOTGSS_EOI_OFFSET;
>> + omap->irq0_offset = USBOTGSS_IRQ0_OFFSET;
>> + omap->irqmisc_offset = USBOTGSS_IRQMISC_OFFSET;
>> + omap->utmi_otg_offset = USBOTGSS_UTMI_OTG_OFFSET;
>> + omap->debug_offset = USBOTGSS_DEBUG_OFFSET;
>> + break;
>> + }
>> +
>> + /* For OMAP5(ES2.0) and AM437x x_major is 2 even though there are
>> + * changes in wrapper registers, Using dt compatible for aegis
>> + */
>> +
>> + if (of_device_is_compatible(node, "ti,am437x-dwc3")) {
>> + omap->irq_eoi_offset = USBOTGSS_EOI_OFFSET;
>> + omap->irq0_offset = USBOTGSS_IRQ0_OFFSET;
>> + omap->irqmisc_offset = USBOTGSS_IRQMISC_OFFSET;
>> + omap->utmi_otg_offset = USBOTGSS_UTMI_OTG_OFFSET;
>> + omap->debug_offset = USBOTGSS_DEBUG_OFFSET;
>> + }
> can you add a patch before $subject which gets rid of the switch
> statement above since it's pretty much useless now that we use
> compatible strings to differentiate omap5 and am437x ?'
okay will do in v2.
>
--
-George
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists