[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.10.1406042337110.18296@nanos>
Date: Wed, 4 Jun 2014 23:54:43 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: Jason Low <jason.low2@...com>
cc: Peter Zijlstra <peterz@...radead.org>, mingo@...nel.org,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
paulmck@...ux.vnet.ibm.com, tim.c.chen@...ux.intel.com,
peter@...leysoftware.com, riel@...hat.com, hpa@...or.com,
walken@...gle.com, davidlohr@...com, Waiman.Long@...com,
aswin@...com, scott.norton@...com, chegu_vinod@...com
Subject: Re: [RFC PATCH 1/3] locking/mutex: Try to acquire mutex only if it
is unlocked
On Wed, 4 Jun 2014, Jason Low wrote:
> On Wed, 2014-06-04 at 21:43 +0200, Peter Zijlstra wrote:
> > > /*
> > > * A negative mutex count indicates that waiters are sleeping waiting for the
> > > - * mutex.
> > > + * mutex, and a count of one indicates the mutex is unlocked.
> > > */
> > > #define MUTEX_SHOW_NO_WAITER(mutex) (atomic_read(&(mutex)->count) >= 0)
> > > +#define MUTEX_IS_UNLOCKED(mutex) (atomic_read(&(mutex)->count) == 1)
> >
> > So I recently saw that MUTEX_SHOW_NO_WAITER thing and cried a little;
> > and now you're adding more of that same nonsense.
> >
> > Please make them inline functions, also can we rename the SHOW_NO_WAITER
> > thing, because its not at all clear to me wtf it does; should it be
> > called: mutex_no_waiters() or somesuch?
>
> Okay, I can make them inline functions. I mainly added the macro to keep
> it consistent with the MUTEX_SHOW_NO_WAITER() check, but we can surely
Consistency with a digusting and nonsensical macro is not really a
good argument.
> make this more clear. mutex_no_waiters() sounds fine, or perhaps
> something like mutex_has_no_waiters()?
Uuurg. So we end up with
if (!mutex_has_no_waiters(m))
if we check for waiters?
Can we please go with the most intuitive thing:
mutex_has_waiters()
and have the callsites prepend the '!' in case they want to check
there is no waiter?
For heavens sake, we do not name macros/inlines in a way which fits
the intended use case. We name them so they make sense.
Your change log blurbs about readability. I have no idea what your
understandig of readability is, but neither MUTEX_SHOW_NO_WAITERS nor
mutex_has_no_waiters qualify for me. Ditto for MUTEX_IS_UNLOCKED.
Care to look at the other lock implementations:
rt_mutex_has_waiters()
spin_is_locked()
....
Why would it make sense to come up with reverse conventions for mutex?
Thanks,
tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists