lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 12 Jun 2014 22:28:37 +0530
From:	Jassi Brar <jaswinder.singh@...aro.org>
To:	linux-kernel@...r.kernel.org
Cc:	devicetree@...r.kernel.org, mporter@...aro.org, patches@...aro.org,
	bjorn@...o.se, ashwin.chaugule@...aro.org,
	gregkh@...uxfoundation.org, s-anna@...com, loic.pallardy@...com,
	lftan.linux@...il.com, slapdau@...oo.com.au,
	courtney.cavin@...ymobile.com, pawel.moll@....com,
	robh+dt@...nel.org, mark.rutland@....com,
	ijc+devicetree@...lion.org.uk, arnd@...db.de, joshc@...eaurora.org,
	linus.walleij@...aro.org, galak@...eaurora.org, ks.giri@...sung.com
Subject: [PATCHv7 0/5] Common Mailbox Framework

Hello,
  Here is the next revision of Mailbox framwork.

Changes since v6:
 o Separate out generic DT bindings patch.
 o Discard unnecessary aligned attributes.

Changes since v5:
 o Use standard error types instead of special type mbox_result.
 o Constify client struct in request_channel
 o Use reinit_completion instead of init_completion every time.
 o Improve commentary in bindings and code.

Changes since v4:
 o Common DT binding for Controller and Client drivers
    As a result, discard string based channel matching
 o Provide for an atomic 'peek' api, that a client could
    call to trigger the controller driver push data upwards.
 o OMAP and Highbank conversion to new api is left out, which
    can be converted later by the developers.

Changes since v3:
 o Change name of symbols from ipc to mbox
 o Return real types instead of void *
 o Align structures
 o Change some symbol names
	rxcb -> rx_callback
	txcb -> tx_done
 o Added kernel-doc for exported API
 o Dropped the cl_id and use clients pointer for callbacks.
 o Fixed locking of channel pool
 o Return negative error code for unsuccessful ipc_send_message()
 o Module referencing during mailbox assignment to a client.
 o Made error code symbols specific to mailbox.

Thanks
Jassi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists