[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1402602866.9617.16.camel@j-VirtualBox>
Date: Thu, 12 Jun 2014 12:54:26 -0700
From: Jason Low <jason.low2@...com>
To: Davidlohr Bueso <davidlohr@...com>
Cc: mingo@...nel.org, peterz@...radead.org, tglx@...utronix.de,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
tim.c.chen@...ux.intel.com, paulmck@...ux.vnet.ibm.com,
rostedt@...dmis.org, Waiman.Long@...com, scott.norton@...com,
aswin@...com
Subject: Re: [PATCH v2 3/4] mutex: Try to acquire mutex only if it is
unlocked
On Thu, 2014-06-12 at 12:37 -0700, Davidlohr Bueso wrote:
> On Wed, 2014-06-11 at 11:37 -0700, Jason Low wrote:
> > Upon entering the slowpath in __mutex_lock_common(), we try once more to
> > acquire the mutex. We only try to acquire if (lock->count >= 0). However,
> > what we actually want here is to try to acquire if the mutex is unlocked
> > (lock->count == 1).
> >
> > This patch changes it so that we only try-acquire the mutex upon entering
> > the slowpath if it is unlocked, rather than if the lock count is non-negative.
> > This helps further reduce unnecessary atomic xchg() operations.
> >
> > Furthermore, this patch uses !mutex_is_locked(lock) to do the initial
> > checks for if the lock is free rather than directly calling atomic_read()
> > on the lock->count, in order to improve readability.
>
> I think this patch can be merged in 2/4, like you had in v1. Otherwise
> looks good.
Ah, I was thinking that removing the macro would be considered a
separate change whereas this 3/4 patch was more of an "optimization".
But yes, those 2 patches could also have been kept as 1 patch as well.
Thanks for the reviews David and Waiman.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists