lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 16 Jun 2014 16:13:41 -0700
From:	Andrew Morton <>
To:	Michal Nazarewicz <>
Cc:	Christoph Lameter <>,,
Subject: Re: [PATCH] mm: page_alloc: simplify drain_zone_pages by using

On Mon, 16 Jun 2014 23:08:14 +0200 Michal Nazarewicz <> wrote:

> Instead of open-coding getting minimal value of two, just use min macro.
> That is why it is there for.  While changing the function also change
> type of batch local variable to match type of per_cpu_pages::batch
> (which is int).

I'm not sure why we made all the per_cpu_pages mambers `int'.  Unsigned
would make more sense.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists