[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKohpom76zu0ec0rgcVH8J5hmAypS9WJ+i_bB43P3aFYzDW2Mw@mail.gmail.com>
Date: Fri, 20 Jun 2014 13:49:36 +0530
From: Viresh Kumar <viresh.kumar@...aro.org>
To: Thomas Gleixner <tglx@...utronix.de>
Cc: LKML <linux-kernel@...r.kernel.org>,
Jason Cooper <jason@...edaemon.net>,
Shiraz Hashim <shiraz.linux.kernel@...il.com>,
spear-devel <spear-devel@...t.st.com>
Subject: Re: [patch 08/13] irqchip: spear_shirq: Precalculate status mask
On 20 June 2014 13:36, Thomas Gleixner <tglx@...utronix.de> wrote:
> On Fri, 20 Jun 2014, Viresh Kumar wrote:
>> On Fri, Jun 20, 2014 at 3:04 AM, Thomas Gleixner <tglx@...utronix.de> wrote:
>> > @@ -176,6 +186,7 @@ static struct spear_shirq spear320_shirq
>> > static struct spear_shirq spear320_shirq_intrcomm_ras = {
>> > .offset = 11,
>> > .nr_irqs = 11,
>> > + .mask = ((0x1 << 11) - 1) << 11,
>> > .regs = {
>> > .enb_reg = -1,
>> > .status_reg = SPEAR320_INT_STS_MASK_REG,
>>
>> If you like, maybe this instead of above diff:
>
> What's wrong with letting the compiler fill it in?
>> + shirq_blocks[i]->mask = ((0x1 << shirq_blocks[i]->nr_irqs) - 1)
>> + << shirq_blocks[i]->offset;
Just for better readability as it doesn't have magic numbers in it
and the performance impact wouldn't be much as its done just
once on boot.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists