[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <53A46D59.1000505@sr71.net>
Date: Fri, 20 Jun 2014 10:20:25 -0700
From: Dave Hansen <dave@...1.net>
To: "H. Peter Anvin" <hpa@...or.com>, linux-kernel@...r.kernel.org
CC: bp@...en8.de, x86@...nel.org
Subject: Re: [RFC][PATCH 1/3] x86: introduce disabled-features
On 06/20/2014 09:20 AM, H. Peter Anvin wrote:
>> > +#ifdef CONFIG_X86_INTEL_MPX
>> > +# define HAVE_MPX (1<<(X86_FEATURE_MPX & 31))
>> > +#else
>> > +# define HAVE_MPX 0
>> > +#endif
>> > +
> Is this an inverted test?
Yes, that was inverted. I've renamed it to make it a bit easier to read:
#ifdef CONFIG_X86_INTEL_MPX
# define DISABLE_MPX 0
#else
# define DISABLE_MPX (1<<(X86_FEATURE_MPX & 31))
#endif
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists