lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 30 Jun 2014 19:51:00 +0100
From:	Nick Warne <>
To:	Borislav Petkov <>
Subject: Re: 3.15.2 build error on AMD64

On 30/06/14 14:26, Borislav Petkov wrote:
> On Sun, Jun 29, 2014 at 11:24:23PM +0200, Borislav Petkov wrote:
>> Btw, I thought you had that gcc 4.2.x from some distro or so. Because
>> if it is in some ancient distro, one could install it in kvm and test
>> and play with it.
> Ok, I did dig out an ancient debian I had lying around here with gcc
> 4.1.2. The patch I pointed you at does really fix the issue. So all is
> fine and solved now. :-)

Ummm, interesting.

But is it solved?

Suppose developer a.n.other submits a patch that works with his/her GCC 
version but doesn't with some other GCC version.  I guess this will be 
picked up in GIT build tests, but that only then tells everybody to 
upgrade GCC or find a patch that fixes the issue (like you did, but I 
couldn't find it).

Is there a document or something that stipulates what is the minimum 
version[s] of GCC to build a particular version of the kernel?  If not, 
perhaps this is something that needs addressing.

"A bug in the code is worth two in the documentation."
FSF Associate Member 5508
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists