[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1404588615-14722-2-git-send-email-apelete@seketeli.net>
Date: Sat, 5 Jul 2014 21:30:15 +0200
From: Apelete Seketeli <apelete@...eteli.net>
To: Ralf Baechle <ralf@...ux-mips.org>,
Lars-Peter Clausen <lars@...afoo.de>,
John Crispin <blogic@...nwrt.org>,
Paul Gortmaker <paul.gortmaker@...driver.com>,
Vinod Koul <vinod.koul@...el.com>, linux-mips@...ux-mips.org
Cc: linux-kernel@...r.kernel.org
Subject: [PATCH v2] mips: jz4740: rename usb_nop_xceiv to usb_phy_generic
Rename usb_nop_xceiv to usb_phy_generic in platform data to match the
name change of the nop transceiver driver in commit 4525bee (usb: phy:
rename usb_nop_xceiv to usb_phy_generic).
The name change induced a kernel panic due to an unhandled kernel
unaligned access while trying to dereference musb->xceiv->io_ops in
musb_init_controller().
Signed-off-by: Apelete Seketeli <apelete@...eteli.net>
---
arch/mips/jz4740/platform.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c
index a447101..0b12f27 100644
--- a/arch/mips/jz4740/platform.c
+++ b/arch/mips/jz4740/platform.c
@@ -59,7 +59,7 @@ struct platform_device jz4740_usb_ohci_device = {
/* USB Device Controller */
struct platform_device jz4740_udc_xceiv_device = {
- .name = "usb_phy_gen_xceiv",
+ .name = "usb_phy_generic",
.id = 0,
};
--
1.7.10.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists