[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <201407100958.02218.marex@denx.de>
Date: Thu, 10 Jul 2014 09:58:02 +0200
From: Marek Vasut <marex@...x.de>
To: Joe Perches <joe@...ches.com>
Cc: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Tadeusz Struk <tadeusz.struk@...el.com>,
Herbert Xu <herbert@...dor.apana.org.au>,
Mauro Carvalho Chehab <m.chehab@...sung.com>,
Helge Deller <deller@....de>,
Ingo Tuchscherer <ingo.tuchscherer@...ibm.com>,
linux390@...ibm.com, Alexander Viro <viro@...iv.linux.org.uk>,
qat-linux@...el.com, linux-crypto@...r.kernel.org,
linux-media@...r.kernel.org, linux-s390@...r.kernel.org,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v1 1/5] seq_file: provide an analogue of print_hex_dump()
On Wednesday, July 09, 2014 at 11:21:08 PM, Joe Perches wrote:
> On Wed, 2014-07-09 at 22:39 +0200, Marek Vasut wrote:
> > The above function looks like almost verbatim copy of print_hex_dump().
> > The only difference I can spot is that it's calling seq_printf() instead
> > of printk(). Can you not instead generalize print_hex_dump() and based
> > on it's invocation, make it call either seq_printf() or printk() ?
>
> How do you propose doing that given any seq_<foo> call
> requires a struct seq_file * and print_hex_dump needs
> a KERN_<LEVEL>.
I can imagine a rather nasty way, I can't say I would like it myself tho. The
general idea would be to pull out the entire switch {} statement into a separate
functions , one for printk() and one for seq_printf() cases. Then, have a
generic do_hex_dump() call which would take as an argument a pointer to either
of those functions and a void * to either the seq_file or level . Finally, there
would have to be a wrapper to call the do_hex_dump() with the correct function
pointer and it's associated arg.
Nasty? Yes ... Ineffective? Most likely.
> Is there an actual value to it?
Reducing the code duplication, but I wonder if there is a smarter solution than
the horrid one above.
Best regards,
Marek Vasut
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists