lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 14 Jul 2014 16:51:30 +0200
From:	Jiri Olsa <jolsa@...hat.com>
To:	Namhyung Kim <namhyung@...nel.org>
Cc:	Jiri Olsa <jolsa@...nel.org>, linux-kernel@...r.kernel.org,
	Arnaldo Carvalho de Melo <acme@...nel.org>,
	Corey Ashford <cjashfor@...ux.vnet.ibm.com>,
	David Ahern <dsahern@...il.com>,
	Frederic Weisbecker <fweisbec@...il.com>,
	Ingo Molnar <mingo@...nel.org>,
	Paul Mackerras <paulus@...ba.org>,
	Peter Zijlstra <a.p.zijlstra@...llo.nl>
Subject: Re: [PATCH 4/4] perf tools: Add --debug optionto set debug variable

On Mon, Jul 14, 2014 at 04:51:06PM +0900, Namhyung Kim wrote:
> Hi Jiri,
> 
> On Sat, 12 Jul 2014 23:56:28 +0200, Jiri Olsa wrote:
> > Adding --debug option as a way to setup debug variables.
> > Starting with support for verbose, more will come.
> >
> > It's possible to use it now with report command:
> >   $ perf report --debug verbose
> >   $ perf report --debug verbose=2
> >
> > I'll need this support to add separated debug variable
> > for ordered events change in order to separate debug
> > output out of standard verbose stream.
> 
> Hmm.. okay.  I think there'll be more users for this.
> 
> 
> >
> > Also removing unneeded getopt.h includes.
> 
> I guess Arnaldo wants to see it as a separate change ;-)

maybe ;-) I hit an issue with this by adding #include "parse-options.h"
into debug.h ... we have a some name clashes with getopt.h

> 
> 
> > +static struct variables_t {
> > +	const char *name;
> > +	int *ptr;
> > +} variables[] = {
> 
> This is a too general name.  How about debug_variable or debug_domain?

debug_variable sounds good to me, will change

thanks,
jirka
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists