lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 18 Jul 2014 16:15:31 -0700
From:	Greg KH <>
To:	Igor Bezukh <>
Subject: Re: [PATCH] Staging: vt6655: apply kernel coding style to
 wCommandTimerWait function

On Fri, Jul 18, 2014 at 09:35:13PM +0300, Igor Bezukh wrote:
> Since there is a lot of stuff that need to be changed in order to meet the kernel
> coding style in wcmd.c file, I've decided to fix function-per-patch.
> The following changes were made in vCommandTimerWait function:
> - Camel case change:
>    - MSecond ---> msec
>    - hDdeviceContext ---> private
>    - pDevice ---> priv
> - Removed redundant return
> - Removed redndant comment
> In future patches, I will also change the function name itself.

A better way to do this, that is easier to review, is to do, on a
per-file basis, one thing, like "remove redundant return", or "remove
unneeded comments".

Having to review all of these changes at once, even for something as
"small" as a single function, is much harder than making sure you only
do one thing, and do it all at once.

So, can you break it up in this way instead?


greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists