lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Thu, 24 Jul 2014 01:36:53 +0000 From: "Zhang, Tianfei" <tianfei.zhang@...el.com> To: "Kirill A. Shutemov" <kirill@...temov.name>, Matthew Wilcox <willy@...ux.intel.com> CC: "Wilcox, Matthew R" <matthew.r.wilcox@...el.com>, "linux-fsdevel@...r.kernel.org" <linux-fsdevel@...r.kernel.org>, "linux-mm@...ck.org" <linux-mm@...ck.org>, "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org> Subject: RE: [PATCH v8 05/22] Add vm_replace_mixed() It is double page_table_lock issue, should be free-and-realloc will be simple and readability? + if (!pte_none(*pte)) { + if (!replace) + goto out_unlock; + VM_BUG_ON(!mutex_is_locked(&vma->vm_file->f_mapping->i_mmap_mutex)); + pte_unmap_unlock(pte, ptl); + zap_page_range_single(vma, addr, PAGE_SIZE, NULL); + pte = get_locked_pte(mm, addr, &ptl); + } Best, Figo > -----Original Message----- > From: owner-linux-mm@...ck.org [mailto:owner-linux-mm@...ck.org] On > Behalf Of Kirill A. Shutemov > Sent: Wednesday, July 23, 2014 11:55 PM > To: Matthew Wilcox > Cc: Wilcox, Matthew R; linux-fsdevel@...r.kernel.org; linux-mm@...ck.org; > linux-kernel@...r.kernel.org > Subject: Re: [PATCH v8 05/22] Add vm_replace_mixed() > > On Wed, Jul 23, 2014 at 10:27:45AM -0400, Matthew Wilcox wrote: > > On Wed, Jul 23, 2014 at 05:20:48PM +0300, Kirill A. Shutemov wrote: > > > On Wed, Jul 23, 2014 at 09:52:22AM -0400, Matthew Wilcox wrote: > > > > I'd love to use a lighter-weight weapon! What would you recommend > > > > using, zap_pte_range()? > > > > > > The most straight-forward way: extract body of pte cycle from > > > zap_pte_range() to separate function -- zap_pte() -- and use it. > > > > OK, I can do that. What about the other parts of zap_page_range(), do > > I need to call them? > > > > lru_add_drain(); > > No, I guess.. > > > tlb_gather_mmu(&tlb, mm, address, end); > > tlb_finish_mmu(&tlb, address, end); > > New zap_pte() should tolerate tlb == NULL and does flush_tlb_page() or > pte_clear_*flush or something. > > > update_hiwater_rss(mm); > > No: you cannot end up with lower rss after replace, iiuc. > > > mmu_notifier_invalidate_range_start(mm, address, end); > > mmu_notifier_invalidate_range_end(mm, address, end); > > mmu_notifier_invalidate_page() should be enough. > > > > > if ((fd = open(argv[1], O_CREAT|O_RDWR, 0666)) < 0) { > > > > perror(argv[1]); > > > > exit(1); > > > > } > > > > > > > > if (ftruncate(fd, 4096) < 0) { > > > > > > Shouldn't this be ftruncate(fd, 0)? Otherwise the memcpy() below > > > will fault in page from backing storage, not hole and write will not > > > replace anything. > > > > Ah, it was starting with a new file, hence the O_CREAT up above. > > Do you mean you pointed to new file all the time? O_CREAT doesn't truncate > file if it exists, iirc. > > -- > Kirill A. Shutemov > > -- > To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to > majordomo@...ck.org. For more info on Linux MM, > see: http://www.linux-mm.org/ . > Don't email: <a href=mailto:"dont@...ck.org"> email@...ck.org </a> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@...r.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists