[<prev] [next>] [day] [month] [year] [list]
Message-ID: <20140724155559.GC22390@kvack.org>
Date: Thu, 24 Jul 2014 11:55:59 -0400
From: Benjamin LaHaise <bcrl@...ck.org>
To: Gu Zheng <guz.fnst@...fujitsu.com>
Cc: axboe@...nel.dk, akpm@...ux-foundation.org, jmoyer@...hat.com,
linux-aio@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [RESEND PATCH 2/4] aio: use the macro rather than the inline magic number
On Wed, Jul 23, 2014 at 06:03:52PM +0800, Gu Zheng wrote:
> Replace the inline magic number with the ready-made macro(AIO_RING_MAGIC),
> just clean up.
Thanks Gu -- applied to my aio-next tree at
git://git.kvack.org/~bcrl/aio-next.git .
-ben
> Reviewed-by: Jeff Moyer <jmoyer@...hat.com>
> Signed-off-by: Gu Zheng <guz.fnst@...fujitsu.com>
> ---
> fs/aio.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/fs/aio.c b/fs/aio.c
> index 94546ab..e0f838d 100644
> --- a/fs/aio.c
> +++ b/fs/aio.c
> @@ -201,7 +201,7 @@ static struct dentry *aio_mount(struct file_system_type *fs_type,
> static const struct dentry_operations ops = {
> .d_dname = simple_dname,
> };
> - return mount_pseudo(fs_type, "aio:", NULL, &ops, 0xa10a10a1);
> + return mount_pseudo(fs_type, "aio:", NULL, &ops, AIO_RING_MAGIC);
> }
>
> /* aio_setup
> --
> 1.7.7
--
"Thought is the essence of where you are now."
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists