[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20140724194651.GE17876@moon>
Date: Thu, 24 Jul 2014 23:46:51 +0400
From: Cyrill Gorcunov <gorcunov@...il.com>
To: Serge Hallyn <serge.hallyn@...ntu.com>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
keescook@...omium.org, tj@...nel.org, akpm@...ux-foundation.org,
avagin@...nvz.org, ebiederm@...ssion.com, hpa@...or.com,
serge.hallyn@...onical.com, xemul@...allels.com,
segoon@...nwall.com, kamezawa.hiroyu@...fujitsu.com,
mtk.manpages@...il.com, jln@...gle.com
Subject: Re: [rfc 1/4] mm: Introduce may_adjust_brk helper
On Thu, Jul 24, 2014 at 07:32:25PM +0000, Serge Hallyn wrote:
> Quoting Cyrill Gorcunov (gorcunov@...nvz.org):
> > To eliminate code duplication lets introduce may_adjust_brk
> > helper which we will use in brk() and prctl() syscalls.
> >
> > Signed-off-by: Cyrill Gorcunov <gorcunov@...nvz.org>
> > Cc: Kees Cook <keescook@...omium.org>
> > Cc: Tejun Heo <tj@...nel.org>
> > Cc: Andrew Morton <akpm@...ux-foundation.org>
> > Cc: Andrew Vagin <avagin@...nvz.org>
> > Cc: Eric W. Biederman <ebiederm@...ssion.com>
> > Cc: H. Peter Anvin <hpa@...or.com>
> > Cc: Serge Hallyn <serge.hallyn@...onical.com>
> > Cc: Pavel Emelyanov <xemul@...allels.com>
> > Cc: Vasiliy Kulikov <segoon@...nwall.com>
> > Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
> > Cc: Michael Kerrisk <mtk.manpages@...il.com>
> > Cc: Julien Tinnes <jln@...gle.com>
> > ---
> > include/linux/mm.h | 14 ++++++++++++++
> > 1 file changed, 14 insertions(+)
> >
> > Index: linux-2.6.git/include/linux/mm.h
> > ===================================================================
> > --- linux-2.6.git.orig/include/linux/mm.h
> > +++ linux-2.6.git/include/linux/mm.h
> > @@ -18,6 +18,7 @@
> > #include <linux/pfn.h>
> > #include <linux/bit_spinlock.h>
> > #include <linux/shrinker.h>
> > +#include <linux/resource.h>
> >
> > struct mempolicy;
> > struct anon_vma;
> > @@ -1780,6 +1781,19 @@ extern struct vm_area_struct *copy_vma(s
> > bool *need_rmap_locks);
> > extern void exit_mmap(struct mm_struct *);
> >
> > +static inline int may_adjust_brk(unsigned long rlim,
> > + unsigned long new_brk,
> > + unsigned long start_brk,
> > + unsigned long end_data,
> > + unsigned long start_data)
> > +{
> > + if (rlim < RLIMIT_DATA) {
>
> In the code you're replacing, this was RLIM_INFINITY. Did you really
> mean for this to be RLIMIT_DATA, aka 2?
Good catch, thanks Serge! Better would be to pass the type of resource
(as Kees suggested) here instead of @rlim itself and sure to compare
with RLIM_INFINITY.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists