lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 27 Jul 2014 13:52:47 +0530
From:	zubraz singha <zubrajsingha@...il.com>
To:	linux-kernel@...r.kernel.org
Subject: "copy_to_user" function not working in stable build "2.6.36.4"

Hey Guys,
While writing a read proc entry for Linux kernel (version 2.6.36.4), I
found that the kernel function "copy_to_user" is not working properly.
The kernel function used internally by "copy_to_user" i.e.
"__copy_to_user" works fine and also this same function "copy_to_user"
works quite well on the higher kernel versions,  I tried it on Linux
kernel version 3.14.  The kernel source code for  "2.6.36.4" doesn't
have a definition for a function i.e "_copy_to_user",  which is being
called internally by "copy_to_user". However the function
"_copy_to_user" has a definition  in higher version kernels like 3.14
etc. I cannot update my kernel,  Is there any way I can fix this issue
by manually patching the kernel. There are two possible ways in which
I think it can be solved.

- Write a definition for the _copy_to_user in "2.6.36.4", which will
have the same "access_ok" check and corresponding  "__copy_to_user"
function call.
- Modifying the function "copy_to_user" and adding the "access_ok"
check and the "__copy_to_user" function.

Zubraj
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists