lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 28 Jul 2014 13:09:28 +0100
From:	Ian Abbott <abbotti@....co.uk>
To:	driverdev-devel@...uxdriverproject.org
Cc:	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Ian Abbott <abbotti@....co.uk>,
	H Hartley Sweeten <hartleys@...ionengravers.com>,
	linux-kernel@...r.kernel.org
Subject: [PATCH 0/7] staging: comedi: amplc_pc236: split into separate ISA and PCI drivers

The "amplc_pc236" module is a low-level comedi driver that handles both
ISA boards (Amplicon PC36AT) and PCI boards (Amplicon PCI236).  Since
support for each is controlled by two separate kernel configuration
options, the module needs a small number of CPP conditionals to handle
the three different combinations (not counting the case where neither
option is enabled).

Split the module into three separate modules - "amplc_pci236" for the
Amplicon PCI236, the existing "amplc_pc236" for the PC36AT, and
"amplc_pc236_common" for the common code.

I may rename "amplc_pc236" to "amplc_pc36at" with a module alias to the
old module name, but it's such an old board, it may not be worth it.

1) staging: comedi: amplc_pc236: move static board data
2) staging: comedi: amplc_pc236: don't disable h/w interrupt on detach()
3) staging: comedi: amplc_pc236: add callback to enable/disable
   interrupt
4) staging: comedi: amplc_pc236: combine interrupt enable/disable
   functions
5) staging: comedi: amplc_pc236: add callback to check and clear
   interrupt
6) staging: comedi: amplc_pc236: split into ISA, PCI and common module
7) staging: comedi: amplc_pc236, amplc_pci236: get rid of bustype

I think this warning in PATCH 6 is a false positive:

WARNING: Missing a blank line after declarations
#535: FILE: drivers/staging/comedi/drivers/amplc_pc236.h:33:
+	enum pc236_bustype bustype;
+	void (*intr_update_cb)(struct comedi_device *dev, bool enable);

total: 0 errors, 1 warnings, 856 lines checked

 drivers/staging/comedi/Kconfig                     |   2 +-
 drivers/staging/comedi/drivers/Makefile            |   4 +-
 drivers/staging/comedi/drivers/amplc_pc236.c       | 379 +--------------------
 drivers/staging/comedi/drivers/amplc_pc236.h       |  42 +++
 .../staging/comedi/drivers/amplc_pc236_common.c    | 206 +++++++++++
 drivers/staging/comedi/drivers/amplc_pci236.c      | 161 +++++++++
 6 files changed, 429 insertions(+), 365 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ