[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140809061712.GL9918@twins.programming.kicks-ass.net>
Date: Sat, 9 Aug 2014 08:17:12 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: David Rientjes <rientjes@...gle.com>
Cc: Bart Van Assche <bvanassche@....org>,
Ingo Molnar <mingo@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
"David S. Miller" <davem@...emloft.net>,
linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v3] spin_lock_nested(): Always evaluate second argument
On Fri, Aug 08, 2014 at 02:52:50PM -0700, David Rientjes wrote:
> On Fri, 8 Aug 2014, Bart Van Assche wrote:
>
> > diff --git a/include/linux/spinlock.h b/include/linux/spinlock.h
> > index 3f2867f..262ba4e 100644
> > --- a/include/linux/spinlock.h
> > +++ b/include/linux/spinlock.h
> > @@ -197,7 +197,13 @@ static inline void do_raw_spin_unlock(raw_spinlock_t *lock) __releases(lock)
> > _raw_spin_lock_nest_lock(lock, &(nest_lock)->dep_map); \
> > } while (0)
> > #else
> > -# define raw_spin_lock_nested(lock, subclass) _raw_spin_lock(lock)
> > +/*
> > + * Always evaluate the 'subclass' argument to avoid that the compiler
> > + * warns about set-but-not-used variables when building with
> > + * CONFIG_DEBUG_LOCK_ALLOC=n and with W=1.
> > + */
>
> I was hoping there was going to be a more important reason for this change
> than to avoid compiler warnings, such as an example where someone is doing
> spin_lock_nested(lock, subclass) and the expression for "subclass"
> requires evaluation in all configs.
That would stink, having that argument have side effects. I'd call that
a plain old bug that needs fixing.
Content of type "application/pgp-signature" skipped
Powered by blists - more mailing lists