[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20140811180542.GI13871@arm.com>
Date: Mon, 11 Aug 2014 19:05:42 +0100
From: Catalin Marinas <catalin.marinas@....com>
To: Laura Abbott <lauraa@...eaurora.org>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
David Riley <davidriley@...omium.org>,
Arnd Bergmann <arnd@...db.de>,
Will Deacon <Will.Deacon@....com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-mm@...ck.org" <linux-mm@...ck.org>,
Thierry Reding <thierry.reding@...il.com>,
Ritesh Harjain <ritesh.harjani@...il.com>,
Russell King <linux@....linux.org.uk>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>
Subject: Re: [PATCHv6 3/5] common: dma-mapping: Introduce common remapping
functions
On Sat, Aug 09, 2014 at 12:25:58AM +0100, Laura Abbott wrote:
> On 8/8/2014 3:45 PM, Andrew Morton wrote:
> > On Fri, 8 Aug 2014 13:23:15 -0700 Laura Abbott <lauraa@...eaurora.org> wrote:
> >> For architectures without coherent DMA, memory for DMA may
> >> need to be remapped with coherent attributes. Factor out
> >> the the remapping code from arm and put it in a
> >> common location to reduce code duplication.
> >>
> >> As part of this, the arm APIs are now migrated away from
> >> ioremap_page_range to the common APIs which use map_vm_area for remapping.
> >> This should be an equivalent change and using map_vm_area is more
> >> correct as ioremap_page_range is intended to bring in io addresses
> >> into the cpu space and not regular kernel managed memory.
> >>
> >> ...
> >>
> >> @@ -267,3 +269,68 @@ int dma_common_mmap(struct device *dev, struct vm_area_struct *vma,
> >> return ret;
> >> }
> >> EXPORT_SYMBOL(dma_common_mmap);
> >> +
> >> +/*
> >> + * remaps an allocated contiguous region into another vm_area.
> >> + * Cannot be used in non-sleeping contexts
> >> + */
> >> +
> >> +void *dma_common_contiguous_remap(struct page *page, size_t size,
> >> + unsigned long vm_flags,
> >> + pgprot_t prot, const void *caller)
> >> +{
> >> + int i;
> >> + struct page **pages;
> >> + void *ptr;
> >> +
> >> + pages = kmalloc(sizeof(struct page *) << get_order(size), GFP_KERNEL);
> >> + if (!pages)
> >> + return NULL;
> >> +
> >> + for (i = 0; i < (size >> PAGE_SHIFT); i++)
> >> + pages[i] = page + i;
> >
> > Assumes a single mem_map[] array. That's not the case for sparsemem
> > (at least).
>
> Good point. I guess the best option is to increment via pfn and call
> pfn_to_page. Either that or go back to slightly abusing
> ioremap_page_range to remap normal memory.
I now noticed you suggested the pfn_to_page(). I think this should work
and it's better than ioremap_page_range().
--
Catalin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists