[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20140813140800.df0310a05e5fad6ed6b55886@linux-foundation.org>
Date: Wed, 13 Aug 2014 14:08:00 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Davidlohr Bueso <davidlohr@...com>
Cc: "Kirill A. Shutemov" <kirill@...temov.name>,
Martin Schwidefsky <schwidefsky@...ibm.com>,
Heiko Carstens <heiko.carstens@...ibm.com>,
"James E.J. Bottomley" <jejb@...isc-linux.org>,
Helge Deller <deller@....de>,
Benjamin Herrenschmidt <benh@...nel.crashing.org>,
Paul Mackerras <paulus@...ba.org>,
Michael Ellerman <mpe@...erman.id.au>,
Robert Richter <rric@...nel.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, aswin@...com
Subject: Re: [PATCH] mm: introduce for_each_vma helpers
On Tue, 12 Aug 2014 16:46:48 -0700 Davidlohr Bueso <davidlohr@...com> wrote:
> On Wed, 2014-08-13 at 00:52 +0300, Kirill A. Shutemov wrote:
> > On Tue, Aug 12, 2014 at 10:45:23AM -0700, Davidlohr Bueso wrote:
> > > The most common way of iterating through the list of vmas, is via:
> > > for (vma = mm->mmap; vma; vma = vma->vm_next)
> > >
> > > This patch replaces this logic with a new for_each_vma(vma) helper,
> > > which 1) encapsulates this logic, and 2) make it easier to read.
> >
> > Why does it need to be encapsulated?
> > Do you have problem with reading plain for()?
> >
> > Your for_each_vma(vma) assumes "mm" from the scope. This can be confusing
> > for reader: whether it uses "mm" from the scope or "current->mm". This
> > will lead to very hard to find bug one day.
>
> I think its fairly obvious to see where the mm is coming from -- the
> helpers *do not* necessarily use current, it uses whatever mm was
> already there in the first place. I have not changed anything related to
> this from the callers.
It is a bit of a hand-grenade for those (rare) situations where code is
dealing with other-tasks-mm. It's simple enough to add an `mm' arg?
> The only related change I can think of, is for some callers that do:
>
> for (vma = current->mm->mmap; vma != NULL; vma = vma->vm_next)
>
> So we just add a local mm from current->mm and replace the for() with
> for_each_vma(). I don't see anything particularly ambiguous with that.
Adding a local to support a macro which secretly uses that local is
pretty nasty.
Overall, I'm not really sure that
- for (vma = mm->mmap; vma; vma = vma->vm_next) {
+ for_each_vma(mm, vma) {
is much of an improvement. I'll wait to see what others think...
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists