[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAD=FV=Uvx3PMJRdnm4FKWWx4h3sN0Mn1yG6v245HnKur_3vgqQ@mail.gmail.com>
Date: Tue, 19 Aug 2014 09:05:20 -0700
From: Doug Anderson <dianders@...omium.org>
To: Thierry Reding <thierry.reding@...il.com>
Cc: Heiko Stuebner <heiko@...ech.de>,
Caesar Wang <caesar.wang@...k-chips.com>,
Sonny Rao <sonnyrao@...omium.org>,
Olof Johansson <olof@...om.net>,
Eddie Cai <eddie.cai@...k-chips.com>,
Rob Herring <robh+dt@...nel.org>,
Pawel Moll <pawel.moll@....com>,
Mark Rutland <mark.rutland@....com>,
Ian Campbell <ijc+devicetree@...lion.org.uk>,
Kumar Gala <galak@...eaurora.org>,
linux-pwm <linux-pwm@...r.kernel.org>,
"devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>
Subject: Re: [PATCH 2/4] pwm: rockchip: Allow polarity invert on rk3288
Thierry
On Tue, Aug 19, 2014 at 12:18 AM, Thierry Reding
<thierry.reding@...il.com> wrote:
> On Mon, Aug 18, 2014 at 10:09:07AM -0700, Doug Anderson wrote:
> [...]
>> diff --git a/drivers/pwm/pwm-rockchip.c b/drivers/pwm/pwm-rockchip.c
>> #define PWM_LP_DISABLE (0 << 8)
>>
>> @@ -32,6 +34,7 @@ struct rockchip_pwm_chip {
>> struct pwm_chip chip;
>> struct clk *clk;
>> const struct rockchip_pwm_data *data;
>> + enum pwm_polarity polarity;
>
> Why do you need this field? struct pwm_device already has a copy of it.
OK, good point.
>> @@ -74,10 +78,14 @@ static void rockchip_pwm_set_enable_v2(struct pwm_chip *chip, bool enable)
>> {
>> struct rockchip_pwm_chip *pc = to_rockchip_pwm_chip(chip);
>> u32 enable_conf = PWM_OUTPUT_LEFT | PWM_LP_DISABLE | PWM_ENABLE |
>> - PWM_CONTINUOUS | PWM_DUTY_POSITIVE |
>> - PWM_INACTIVE_NEGATIVE;
>> + PWM_CONTINUOUS;
>> u32 val;
>>
>> + if (pc->polarity == PWM_POLARITY_INVERSED)
>> + enable_conf |= PWM_DUTY_NEGATIVE | PWM_INACTIVE_POSITIVE;
>> + else
>> + enable_conf |= PWM_DUTY_POSITIVE | PWM_INACTIVE_NEGATIVE;
>
> I have a feeling you're going to answer the above question with: "Because
> it's needed here". If so, my reply would be: "Then this function should
> take a struct pwm_device instead of struct pwm_chip."
OK. I've chosen to have it take a pwm_device AND a pwm_chip. It is a
little redundant because a pwm_device has a pointer to its pwm_chip,
but it follows the lead of all of the callbacks in "struct pwm_ops".
If you'd like me to spin it to take only a pwm_device I'm happy to.
>
>> @@ -173,6 +195,7 @@ static const struct rockchip_pwm_data pwm_data_v2 = {
>> .ctrl = 0x0c,
>> },
>> .prescaler = 1,
>> + .has_invert = 1,
>
> Since has_invert is a boolean, the proper value here would be "true".
Done.
>> @@ -228,6 +252,10 @@ static int rockchip_pwm_probe(struct platform_device *pdev)
>> pc->data = id->data;
>> pc->chip.dev = &pdev->dev;
>> pc->chip.ops = &rockchip_pwm_ops;
>> + if (pc->data->has_invert) {
>> + pc->chip.of_xlate = of_pwm_xlate_with_flags;
>> + pc->chip.of_pwm_n_cells = 3;
>> + }
>> pc->chip.base = -1;
>> pc->chip.npwm = 1;
>
> I suggest to rewrite the above as follows for readability:
>
> pc->data = id->data;
> pc->chip.dev = &pdev->dev;
> pc->chip.ops = &rockchip_pwm_ops;
> pc->chip.base = -1;
> pc->chip.npwm = 1;
Done.
> + if (pc->data->has_invert) {
> + pc->chip.of_xlate = of_pwm_xlate_with_flags;
> + pc->chip.of_pwm_n_cells = 3;
> + }
>
> Thierry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists