[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <yq1sikpr2nk.fsf@sermon.lab.mkp.net>
Date: Thu, 21 Aug 2014 16:47:11 -0400
From: "Martin K. Petersen" <martin.petersen@...cle.com>
To: Sreekanth Reddy <sreekanth.reddy@...gotech.com>
Cc: martin.petersen@...cle.com, jejb@...nel.org,
linux-scsi@...r.kernel.org, JBottomley@...allels.com,
Sathya.Prakash@...gotech.com, Nagalakshmi.Nandigama@...gotech.com,
linux-kernel@...r.kernel.org, hch@...radead.org
Subject: Re: [PATCH 08/10] [scsi] mpt2sas: Get IOC_FACTS information using handshake protocol only after HBA card gets into READY or Operational state.
>>>>> "Sreekanth" == Sreekanth Reddy <sreekanth.reddy@...gotech.com> writes:
Sreekanth,
+ if (((ioc_state & MPI2_IOC_STATE_MASK) == MPI2_IOC_STATE_READY) ||
+ (ioc_state & MPI2_IOC_STATE_MASK) == MPI2_IOC_STATE_OPERATIONAL)
+ return 0;
I find the following easier to read:
switch (ioc_state & MPI2_IOC_STATE_MASK) {
case MPI2_IOC_STATE_READY:
case MPI2_IOC_STATE_OPERATIONAL:
return 0;
}
but that's just personal preference...
+ if (ioc_state & MPI2_DOORBELL_USED) {
+ dhsprintk(ioc, printk(MPT2SAS_INFO_FMT
+ "unexpected doorbell activ!e\n", ioc->name));
Typo.
+ if ((ioc_state & MPI2_IOC_STATE_MASK) == MPI2_IOC_STATE_FAULT) {
ioc_state & MPI2_IOC_STATE_MASK again. Maybe you should just introduce a
variable for that and save a bunch of parentheses?
Otherwise OK.
Reviewed-by: Martin K. Petersen <martin.petersen@...cle.com>
--
Martin K. Petersen Oracle Linux Engineering
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists