[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <53F73B5F.70009@citrix.com>
Date: Fri, 22 Aug 2014 13:45:19 +0100
From: David Vrabel <david.vrabel@...rix.com>
To: Arianna Avanzini <avanzini.arianna@...il.com>,
<konrad.wilk@...cle.com>, <boris.ostrovsky@...cle.com>,
<xen-devel@...ts.xenproject.org>, <linux-kernel@...r.kernel.org>
CC: <bob.liu@...cle.com>, <felipe.franciosi@...rix.com>, <axboe@...com>
Subject: Re: [PATCH RFC 2/4] xen, blkfront: factor out flush-related checks
from do_blkif_request()
On 22/08/14 12:20, Arianna Avanzini wrote:
> This commit factors out some checks related to the request insertion
> path, which now are performed by both the multi-queue and the request-
> queue hooks. This commit introduces no functional change.
>
> Signed-off-by: Arianna Avanzini <avanzini.arianna@...il.com>
> ---
> drivers/block/xen-blkfront.c | 16 ++++++++++------
> 1 file changed, 10 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
> index 0407ad5..a047346 100644
> --- a/drivers/block/xen-blkfront.c
> +++ b/drivers/block/xen-blkfront.c
> @@ -588,6 +588,14 @@ static inline void flush_requests(struct blkfront_info *info)
> notify_remote_via_irq(info->irq);
> }
>
> +static inline bool blkif_request_flush_mismatch(struct request *req,
> + struct blkfront_info *info)
blkif_request_flush_valid() is a better name/sense, I think.
Otherwise,
Reviewed-by: David Vrabel <david.vrabel@...rix.com>
David
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists