[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-id: <1409812338-16012-1-git-send-email-r.baldyga@samsung.com>
Date: Thu, 04 Sep 2014 08:32:16 +0200
From: Robert Baldyga <r.baldyga@...sung.com>
To: balbi@...com
Cc: gregkh@...uxfoundation.org, linux-usb@...r.kernel.org,
linux-kernel@...r.kernel.org, mina86@...a86.com,
m.szyprowski@...sung.com, andrzej.p@...sung.com,
k.opasiak@...sung.com, Robert Baldyga <r.baldyga@...sung.com>
Subject: [PATCH v7 0/2] usb: gadget: f_fs: userspace API fixes and improvements
This patchset contains changes in FunctionFS making it easier and
safer to use. It fixes bug in endpoint files handling code, adds new
ioctl allowing to obtain endpoint descriptor, and introduces virtual
address mapping which allows to separate endpoint address space in
function from physical endpoint addresses, and introduces new endpoint
files naming convention.
Changelog:
v7:
- return proper value from ffs_epfile_ioctl() function
- remove patch "usb: gadget: f_fs: fix the redundant ep files problem"
from this patchset because it's already in Gregs tree
v6: https://lkml.org/lkml/2014/8/25/101
- unlock spinlock before copy_to_user() call
- remove duplicated eps_count value check
- few minor fixes
v5: https://lkml.org/lkml/2014/8/21/252
- fix typo pointed by Sergei Shtylyov
v4: https://lkml.org/lkml/2014/8/20/277
- change if() sequence into switch() statement
v3: https://lkml.org/lkml/2014/7/30/115
- move fix for the redundant ep files problem into sepatare patch
- merge user space API affecting changes into single patch
- add flag switching between old and new style API
v2: https://lkml.org/lkml/2014/7/25/296
- return proper endpont address in setup request handling
- add patch usb: gadget: f_fs: add ioctl returning ep descriptor
- add patch usb: gadget: f_fs: make numbers in ep file names the same
as ep addresses
v1: https://lkml.org/lkml/2014/7/18/1010
Robert Baldyga (2):
usb: gadget: f_fs: add ioctl returning ep descriptor
usb: gadget: f_fs: virtual endpoint address mapping
drivers/usb/gadget/function/f_fs.c | 46 +++++++++++++++++++++++++++++++++++--
drivers/usb/gadget/function/u_fs.h | 2 ++
include/uapi/linux/usb/functionfs.h | 7 ++++++
3 files changed, 53 insertions(+), 2 deletions(-)
--
1.9.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists