lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 4 Sep 2014 18:51:49 +0200
From:	Denys Vlasenko <vda.linux@...glemail.com>
To:	Oleg Nesterov <oleg@...hat.com>
Cc:	"H. Peter Anvin" <hpa@...or.com>,
	Andy Lutomirski <luto@...capital.net>,
	Denys Vlasenko <dvlasenk@...hat.com>,
	Ingo Molnar <mingo@...nel.org>,
	Peter Zijlstra <peterz@...radead.org>, X86 ML <x86@...nel.org>,
	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

On Thu, Sep 4, 2014 at 3:42 PM, Oleg Nesterov <oleg@...hat.com> wrote:
> -#ifdef CONFIG_TRACE_IRQFLAGS
>         /* put return address in eax (arg1) */
> -       .macro thunk_ra name,func
> +       .macro thunk_ra name, func, put_ret_addr_in_eax=0
>         .globl \name
>  \name:
>         pushl %eax
>         pushl %ecx
>         pushl %edx
> +
> +       .if \put_ret_addr_in_eax
>         /* Place EIP in the arg1 */
>         movl 3*4(%esp), %eax
> +       .endif
> +
>         call \func
>         popl %edx
>         popl %ecx
> @@ -25,6 +28,15 @@
>         _ASM_NOKPROBE(\name)
>         .endm
>
> -       thunk_ra trace_hardirqs_on_thunk,trace_hardirqs_on_caller
> -       thunk_ra trace_hardirqs_off_thunk,trace_hardirqs_off_caller
> +#ifdef CONFIG_TRACE_IRQFLAGS
> +       thunk_ra trace_hardirqs_on_thunk,trace_hardirqs_on_caller,1
> +       thunk_ra trace_hardirqs_off_thunk,trace_hardirqs_off_caller,1
> +#endif
> +
> +#ifdef CONFIG_PREEMPT
> +       THUNK ___preempt_schedule, preempt_schedule
> +#ifdef CONFIG_CONTEXT_TRACKING
> +       THUNK ___preempt_schedule_context, preempt_schedule_context
>  #endif
> +#endif


I think THUNK should be thunk_ra here;
or thunk_ra should be renamed to THUNK (like it is in thunk_64.S)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ