[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20140911125436.51338d98e8e84abacc418aff@linux-foundation.org>
Date: Thu, 11 Sep 2014 12:54:36 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Peter Feiner <pfeiner@...gle.com>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org,
"Kirill A. Shutemov" <kirill@...temov.name>,
Cyrill Gorcunov <gorcunov@...nvz.org>,
Pavel Emelyanov <xemul@...allels.com>,
Jamie Liu <jamieliu@...gle.com>,
Hugh Dickins <hughd@...gle.com>,
Naoya Horiguchi <n-horiguchi@...jp.nec.com>
Subject: Re: [PATCH] mm: softdirty: unmapped addresses between VMAs are
clean
On Wed, 10 Sep 2014 22:41:04 -0700 Peter Feiner <pfeiner@...gle.com> wrote:
> On Wed, Sep 10, 2014 at 04:36:28PM -0700, Andrew Morton wrote:
> > On Wed, 10 Sep 2014 16:24:46 -0700 Peter Feiner <pfeiner@...gle.com> wrote:
> > > @@ -1048,32 +1048,51 @@ static int pagemap_pte_range(pmd_t *pmd, unsigned long addr, unsigned long end,
> > > + while (1) {
> > > + unsigned long vm_start = end;
> >
> > Did you really mean to do that? If so, perhaps a little comment to
> > explain how it works?
>
> It's the same idea that I used in the pagemap_pte_hole patch that I submitted
> today: if vma is NULL, then we fill in the pagemap from (addr) to (end) with
> non-present pagemap entries.
>
> Should I submit a v2 with a comment?
I spent quite some time staring at that code wondering wtf, so anything
you can do to clarify it would be good.
I think a better name would be plain old "start", to communicate that
it's just a local convenience variable. "vm_start" means "start of a
vma" and that isn't accurate in this context; in fact it is misleading.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists