lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 17 Sep 2014 14:37:10 +0200
From:	Ingo Molnar <mingo@...nel.org>
To:	Nadav Amit <nadav.amit@...il.com>
Cc:	Nadav Amit <namit@...technion.ac.il>, pbonzini@...hat.com,
	hpa@...or.com, mingo@...hat.com, tglx@...utronix.de,
	x86@...nel.org, kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Peter Zijlstra <a.p.zijlstra@...llo.nl>,
	Borislav Petkov <bp@...en8.de>
Subject: Re: [PATCH 0/3] x86: structs for cpuid info in x86


* Nadav Amit <nadav.amit@...il.com> wrote:

> 
> 
> On 9/16/14 4:22 PM, Ingo Molnar wrote:
> > 
> > * Nadav Amit <namit@...technion.ac.il> wrote:
> > 
> >> The code that deals with x86 cpuid fields is hard to follow since it performs
> >> many bit operations and does not refer to cpuid field explicitly.  To
> >> eliminate the need of openning a spec whenever dealing with cpuid fields, this
> >> patch-set introduces structs that reflect the various cpuid functions.
> >>
> >> Thanks for reviewing the patch-set.
> >>
> >> Nadav Amit (3):
> >>   x86: Adding structs to reflect cpuid fields
> >>   x86: Use new cpuid structs in cpuid functions
> >>   KVM: x86: Using cpuid structs in KVM
> >>
> >>  arch/x86/include/asm/cpuid_def.h | 163 +++++++++++++++++++++++++++++++++++++++
> >>  arch/x86/kernel/cpu/common.c     |  56 ++++++++------
> >>  arch/x86/kvm/cpuid.c             |  36 +++++----
> >>  3 files changed, 219 insertions(+), 36 deletions(-)
> >>  create mode 100644 arch/x86/include/asm/cpuid_def.h
> > 
> > I personally like bitfields in theory (they provide type clarity 
> > and abstract robustness, compared to open-coded bitmask numeric 
> > literals that are often used in cpuid using code, obfuscating 
> > cpuid usage), with the big caveat that for many years I didn't 
> > like bitfields in practice: older versions of GCC did a really 
> > poor job of optimizing them.
> > 
> > So such a series would only be acceptable if it's demonstrated 
> > that both 'latest' and 'reasonably old' GCC versions do a good 
> > job in that department, compared to the old open-coded bitmask 
> > ops ...
> > 
> > Comparing the 'size vmlinux' output of before/after kernels would 
> > probably be a good start in seeing the impact of such a change.
> > 
> > If those results are positive then this technique could be 
> > propagated to all cpuid using code in arch/x86/, of which
> > there's plenty.
> 
> Thanks for the quick response. I was not aware GCC behaves this 
> way. I made some small experiments with GCC-4.8 and GCC-4.4 and 
> in brief my conclusions are:
>
> 1. The assembled code of bitmask and bitfields is indeed different.
> 2. GCC-4.8 and GCC-4.4 behave pretty much the same, yet GCC-4.8 appears
> to make better instructions reordering.
> 3. Loading/storing a single bitfield seems to be pretty much optimized
> (marginal advantage from code size point-of-view for bitmask, same
> number of instructions).
> 4. Loading/storing multiple bitfields seems to be somewhat
> under-optimized - multiple accesses to the original value result in ~30%
> more instructions and code-size.

That's better than what I remembered.

> So you are correct - bitfields are less optimized. Nonetheless, 
> since cpuid data is mostly used during startup, and otherwise a 
> single bitfield is usually accessed in each function - I wonder 
> whether it worth keeping the optimized but "obfuscate" code. 
> Obviously, I can guess your answer to this question...

So with the condition that you are actively watching out for 
performance critical code paths, I think the type clarity (i.e. 
bitfields) is a win.

If hpa, tglx or Linus objects I'll yield to that objection 
though.

Opinions, objections?

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ