[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140917214027.GM17875@mwanda>
Date: Thu, 18 Sep 2014 00:40:27 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: "Ragnar B. Johannsson" <ragnar@....is>
Cc: gregkh@...uxfoundation.org, gdonald@...il.com,
himangi774@...il.com, joe@...ches.com, joelpelaez@...il.com,
arnd@...db.de, jmmahler@...il.com, peter.p.waskiewicz.jr@...el.com,
antoine@...weitzer-chaput.fr, anarey@...il.com, c@...io,
rickard_strandqvist@...ctrumdigital.se, teobaluta@...il.com,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/1] staging: rtl8192u: Move ieee80211_crypto_*
declarations to ieee80211/ieee80211.h
On Wed, Sep 17, 2014 at 09:24:03PM +0000, Ragnar B. Johannsson wrote:
> diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211.h b/drivers/staging/rtl8192u/ieee80211/ieee80211.h
> index bdad3a2..d56c3aac 100644
> --- a/drivers/staging/rtl8192u/ieee80211/ieee80211.h
> +++ b/drivers/staging/rtl8192u/ieee80211/ieee80211.h
> @@ -2445,6 +2445,15 @@ extern void ieee80211_tkip_null(void);
> extern void ieee80211_wep_null(void);
> extern void ieee80211_ccmp_null(void);
>
> +extern int ieee80211_crypto_init(void);
> +extern void ieee80211_crypto_deinit(void);
> +extern int ieee80211_crypto_tkip_init(void);
> +extern void ieee80211_crypto_tkip_exit(void);
> +extern int ieee80211_crypto_ccmp_init(void);
> +extern void ieee80211_crypto_ccmp_exit(void);
> +extern int ieee80211_crypto_wep_init(void);
> +extern void ieee80211_crypto_wep_exit(void);
> +
We don't normally put the extern here. I don't think it adds anything
to the readability. Let's remove it.
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists