[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1411415590-12193-1-git-send-email-bobby.prani@gmail.com>
Date: Mon, 22 Sep 2014 15:53:09 -0400
From: Pranith Kumar <bobby.prani@...il.com>
To: Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>,
x86@...nel.org (maintainer:X86 ARCHITECTURE...),
Peter Zijlstra <peterz@...radead.org>,
"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
linux-kernel@...r.kernel.org (open list:X86 ARCHITECTURE...)
Subject: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()
Use the much easier to read ACCESS_ONCE() which is basically the same thing as
the cast to volatile.
Please note the change in volatile cast: ACCESS_ONCE(v)->counter to
ACCESS_ONCE(v->counter).
Signed-off-by: Pranith Kumar <bobby.prani@...il.com>
---
arch/x86/include/asm/atomic.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/include/asm/atomic.h b/arch/x86/include/asm/atomic.h
index fa92e93..dea3434 100644
--- a/arch/x86/include/asm/atomic.h
+++ b/arch/x86/include/asm/atomic.h
@@ -24,7 +24,7 @@
*/
static inline int atomic_read(const atomic_t *v)
{
- return (*(volatile int *)&(v)->counter);
+ return ACCESS_ONCE(v->counter);
}
/**
--
2.1.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists