[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5774775.2EcFmuR4sV@wuerfel>
Date: Wed, 24 Sep 2014 11:22:50 +0200
From: Arnd Bergmann <arnd@...db.de>
To: behanw@...verseincode.com
Cc: bcm@...thebug.org, chris@...ntf.net, gnurou@...il.com,
linus.walleij@...aro.org, mporter@...aro.org,
ulf.hansson@...aro.org, bcm-kernel-feedback-list@...adcom.com,
linux-gpio@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-mmc@...r.kernel.org, rjui@...adcom.com
Subject: Re: [PATCH v2 2/2] mmc, sdhci, bcm-kona, LLVMLinux: Remove use of __initconst
On Tuesday 23 September 2014 15:55:08 behanw@...verseincode.com wrote:
> --- a/drivers/mmc/host/sdhci-bcm-kona.c
> +++ b/drivers/mmc/host/sdhci-bcm-kona.c
> @@ -225,7 +225,7 @@ static struct sdhci_pltfm_data sdhci_pltfm_data_kona = {
> SDHCI_QUIRK_CAP_CLOCK_BASE_BROKEN,
> };
>
> -static struct __initconst of_device_id sdhci_bcm_kona_of_match[] = {
> +static struct of_device_id const sdhci_bcm_kona_of_match[] = {
> { .compatible = "brcm,kona-sdhci"},
> { .compatible = "bcm,kona-sdhci"}, /* deprecated name */
> {}
>
Sorry for giving you trouble over such a simple patch (especially
one that I have acked already), but I just noticed that this is
not following the common style we use in the kernel.
Almost everywhere in Linux, we use
static const struct of_device_id sdhci_bcm_kona_of_match[] = {
not
static struct of_device_id const sdhci_bcm_kona_of_match[] = {
AFAICT they behave in identical ways, but the first one seems
easier to read for someone familiar with kernel code.
Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists