lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 1 Oct 2014 19:07:59 +0100
From:	Mark Brown <broonie@...nel.org>
To:	Romain Perier <romain.perier@...il.com>
Cc:	devicetree@...r.kernel.org, lgirdwood@...il.com,
	linux-kernel@...r.kernel.org, heiko@...ech.de
Subject: Re: [RFC][PATCH 1/4] regulator: Add helper function to get
 "poweroff-source" property

On Tue, Sep 30, 2014 at 05:29:43PM +0000, Romain Perier wrote:

> +/**
> + * of_get_regulator_poweroff_source - Get poweroff-source for given device_node
> + * @np: Pointer to the given device_node
> + *
> + * return true if present false otherwise
> + */
> +bool of_get_regulator_poweroff_source(const struct device_node *np)
> +{
> +	return of_property_read_bool(np, "poweroff-source");
> +}
> +EXPORT_SYMBOL_GPL(of_get_regulator_poweroff_source);

This isn't really a regulator specific thing - it's common for the
actual implementation to be to simply cut power but it could be
something that doesn't look like a regulator doing it like a system
monitor.  I'd rename this to something like is_system_poweroff_source().

You probably also want to CC the DT maintainers on this and add some
documentation of this as a standard property, not entirely sure where
exactly but I'm sure the DT people could advise.

Download attachment "signature.asc" of type "application/pgp-signature" (474 bytes)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ