[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87mw8ogaj8.fsf@sejong.aot.lge.com>
Date: Wed, 22 Oct 2014 10:26:03 +0900
From: Namhyung Kim <namhyung@...nel.org>
To: Andi Kleen <andi@...stfloor.org>
Cc: jolsa@...hat.com, linux-kernel@...r.kernel.org, acme@...nel.org,
Andi Kleen <ak@...ux.intel.com>
Subject: Re: [PATCH 2/8] perf, tools: Add --branch-history option to report
On Fri, 26 Sep 2014 16:37:10 -0700, Andi Kleen wrote:
> From: Andi Kleen <ak@...ux.intel.com>
>
> Add a --branch-history option to perf report that changes all
> the settings necessary for using the branches in callstacks.
>
> This is just a short cut to make this nicer to use, it does
> not enable any functionality by itself.
>
> v2: Change sort order. Rename option to --branch-history to
> be less confusing.
> v3: Updates
> v4: Fix conflict with newer perf base
> Signed-off-by: Andi Kleen <ak@...ux.intel.com>
[SNIP]
> @@ -675,7 +686,11 @@ int cmd_report(int argc, const char **argv, const char *prefix __maybe_unused)
> OPT_BOOLEAN(0, "group", &symbol_conf.event_group,
> "Show event group information together"),
> OPT_CALLBACK_NOOPT('b', "branch-stack", &branch_mode, "",
> - "use branch records for histogram filling", parse_branch_mode),
> + "use branch records for per branch histogram filling",
> + parse_branch_mode),
> + OPT_CALLBACK_NOOPT(0, "branch-history", &branch_call_mode, "",
> + "add last branch records to call history",
> + parse_branch_call_mode),
> OPT_STRING(0, "objdump", &objdump_path, "path",
> "objdump binary to use for disassembly and annotations"),
> OPT_BOOLEAN(0, "demangle", &symbol_conf.demangle,
> @@ -732,10 +747,20 @@ repeat:
> has_br_stack = perf_header__has_feat(&session->header,
> HEADER_BRANCH_STACK);
>
> - if ((branch_mode == -1 && has_br_stack) || branch_mode == 1) {
> + if (((branch_mode == -1 && has_br_stack) || branch_mode == 1) &&
> + branch_call_mode == -1) {
> sort__mode = SORT_MODE__BRANCH;
> symbol_conf.cumulate_callchain = false;
> }
> + if (branch_call_mode != -1) {
> + callchain_param.branch_callstack = 1;
> + callchain_param.key = CCKEY_ADDRESS;
I think it'd be better leave this apart from the change. Users might
want use different callchain_param.key when --branch-history is used.
And please also add a new CCKEY_SRCLINE if you print srcline with the
callchains so that users can give "-g srcline" if they want (regardless
of the branch history feature).
> + symbol_conf.use_callchain = true;
> + callchain_register_param(&callchain_param);
> + if (sort_order == default_sort_order)
I guess this won't work with the current code. You can check sort_order
being NULL instead.
Thanks,
Namhyung
> + sort_order = "srcline,symbol,dso";
> + branch_mode = 0;
> + }
>
> if (report.mem_mode) {
> if (sort__mode == SORT_MODE__BRANCH) {
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists