lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 26 Oct 2014 22:55:48 +0100
From:	Pavel Machek <pavel@....cz>
To:	Pali Rohár <pali.rohar@...il.com>
Cc:	Aaro Koskinen <aaro.koskinen@....fi>, Felipe Balbi <balbi@...com>,
	sre@...ian.org, sre@...g0.de,
	kernel list <linux-kernel@...r.kernel.org>,
	linux-arm-kernel@...ts.infradead.org, linux-omap@...r.kernel.org
Subject: Re: USB Ethernet gadget on Nokia n900


> > I have root prepared on /dev/mmcblk0p6. I tried 3.17 with
> > rx51_defconfig, but no, it refuses to mount it.
> > 
> > VFS: Cannot open root device "mmcblk0p6" or ....: error -19.
> > 
> > And then it proceeds to list mmcblk0p6 as one of available
> > options
> > 
> > :-(.
> > 
> > Ideas welcome.
> 
> Try to add rootdelay=30 or rootwait to kernel cmdline.

I had rootdelay=3. Will try rootwait... no change. This is v3.17 with
rx51_defconfig. CONFIG_MACH_NOKIA_RX51=y => device tree will not be
used AFAICT.

Now I'm back at 3.14 without device tree; same setup works there. I
tried disabling RX51 support in 3.14 (to make it boot using device
tree) but that did not work.
								Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists