lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 28 Oct 2014 23:20:15 +0100
From:	Pavel Machek <pavel@....cz>
To:	Stanislaw Gruszka <sgruszka@...hat.com>
Cc:	"Grumbach, Emmanuel" <emmanuel.grumbach@...el.com>,
	kernel list <linux-kernel@...r.kernel.org>,
	"linux-wireless@...r.kernel.org" <linux-wireless@...r.kernel.org>,
	"Berg, Johannes" <johannes.berg@...el.com>,
	"ilw@...ux.intel.com" <ilw@...ux.intel.com>
Subject: Re: 3.18-rc0: iwlegacy failed after a while

On Sun 2014-10-26 12:05:54, Pavel Machek wrote:
> On Sun 2014-10-26 11:33:15, Stanislaw Gruszka wrote:
> > On Sat, Oct 25, 2014 at 01:42:46PM +0200, Pavel Machek wrote:
> > > > Since 3.17 we have only 2 minor iwlegacy changes on current linus tree.
> > > > If this is a regression it's probably caused by different subsystem
> > > > changes, most likely by PCI changes. If this is not regression, such
> > > > errors could be caused by enabling PS, but that has to be done
> > > > explicitly, Pavel did you enable power_save ? 
> > > 
> > > This is running pretty standart MATE desktop, and no, I don't think I
> > > enabled that.
> > 
> > It can be checked by "iw dev wlan0 get power_save" .

So it seems I have power save on. I guess someone enabled it for me :-).

root@duo:~# iwconfig wlan0
wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          
root@duo:~# iw dev wlan0 get power_save
Power save: on
root@duo:~# 

> > More important quiestions: Is this regression, did you see this error
> > before? How reproducible is this problem?
> 
> I've never seen it before, and it only happened once after update to
> 3.18-rc.

Today wifi failed, again. Will reboot. dmesg is in the attachment,
looks like same fail.

									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Download attachment "delme.gz" of type "application/gzip" (20350 bytes)

Powered by blists - more mailing lists