lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 31 Oct 2014 12:51:46 -0400
From:	Steven Rostedt <rostedt@...dmis.org>
To:	byungchul.park@....com
Cc:	Namhyung Kim <namhyung@...nel.org>, Ingo Molnar <mingo@...nel.org>,
	Jiri Olsa <jolsa@...hat.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] tracing, function_graph: fix micro seconds notation
 in comment

On Fri, 24 Oct 2014 10:07:42 +0900
Byungchul Park <byungchul.park@....com> wrote:

 
> > >  	/* Signal a overhead of time execution to the output */
> > >  	if (flags & TRACE_GRAPH_PRINT_OVERHEAD) {
> > > -		/* Duration exceeded 100 msecs */
> > > +		/* Duration exceeded 100 usecs */
> > >  		if (duration > 100000ULL)
> > >  			ret = trace_seq_puts(s, "! ");
> > > -		/* Duration exceeded 10 msecs */
> > > +		/* Duration exceeded 10 usecs */
> > >  		else if (duration > 10000ULL)
> > 
> > I thought the duration was in usec, but it seems not, it's in nsec, hmm.
> > Then this exceeding 10/100 usec is not meaningful - what about increaing
> > numbers in the conditional so that it can match to the comment?  That
> > will eliminate the need of the patch 2.

No, please keep this to 10/100 usecs. I do analyze functions that take
that little of time.

> 
> The approach you suggested also looks good to me. But I just wonder if it
> would be ok even if it changes meaning of the marks, "!", "+", because the
> marks have used with the meaning of exceeding 10/100 usec until now.
> 
> Isn't there anything wrong with increasing numbers in the conditions? :)
> 
> > 
> > Also I think msecs_str in trace_print_graph_duration() should be renamed
> > to usecs_str.
> 
> I agree. It should be also renamed. Such words made me hard to understand
> the code correctly. :(
> 

Yeah, this code has been here forever. It came from the original
latency-tracer in the -rt patch. I was so use to calling 'msecs' as
microseconds in this code, that I didn't realize the problem ;-)

Anyway, feel free to resend this patch fixing the msecs_str.

Thanks!

-- Steve


> > 
> > Thanks,
> > Namhyung
> > 
> > 
> > >  			ret = trace_seq_puts(s, "+ ");
> > >  	}
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@...r.kernel.org
> > More majordomo info at  http://vger.kernel.org/majordomo-info.html
> > Please read the FAQ at  http://www.tux.org/lkml/

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ