lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 4 Nov 2014 09:29:01 +0100
From:	Peter Zijlstra <peterz@...radead.org>
To:	Maxime COQUELIN <maxime.coquelin@...com>
Cc:	gong.chen@...ux.intel.com, Ingo Molnar <mingo@...nel.org>,
	" Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>, tytso@....edu,
	linux-kernel@...r.kernel.org, stable@...r.kernel.org,
	kernel@...inux.com, eric.paire@...com
Subject: Re: [PATCH] bitops: Fix shift overflow in GENMASK macros

On Mon, Nov 03, 2014 at 06:39:58PM +0100, Maxime COQUELIN wrote:
> On some 32 bits architectures, including x86, GENMASK(31, 0) returns 0
> instead of the expected ~0UL.
> 
> This is the same on some 64 bits architectures with GENMASK_ULL(63, 0).
> 
> This is due to an overflow in the shift operand, 1 << 32 for GENMASK,
> 1 << 64 for GENMASK_ULL.
> 
> Fixes: 10ef6b0dffe404bcc54e94cb2ca1a5b18445a66b
> Cc: <stable@...r.kernel.org> #v3.13+
> Reported-by: Eric Paire <eric.paire@...com>
> Signed-off-by: Maxime Coquelin <maxime.coquelin@...com>
> ---
>  include/linux/bitops.h | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/bitops.h b/include/linux/bitops.h
> index be5fd38..81f9725 100644
> --- a/include/linux/bitops.h
> +++ b/include/linux/bitops.h
> @@ -18,8 +18,12 @@
>   * position @h. For example
>   * GENMASK_ULL(39, 21) gives us the 64bit vector 0x000000ffffe00000.
>   */
> -#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
> -#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
> +#define GENMASK(h, l) \
> +	((~0UL >> ((BITS_PER_LONG - 1) - (h))) & ~((1UL << (l)) - 1))
> +
> +#define GENMASK_ULL(h, l) \
> +	((~0ULL >> ((BITS_PER_LONG_LONG - 1) - (h))) & ~((1ULL << (l)) - 1))
> +

I was not expecting the mask there, but instead something like:

	((~0UL >> (BITS_PER_LONG - (h-l+1))) << l)

which shifts the bits to the desired length and then back to the desired
place. Would that not be more readable?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ