[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CADcy93Ve8LogFqTz6_nev43CrrtCqgP23_-Twpze6L3V1rnkbw@mail.gmail.com>
Date: Tue, 18 Nov 2014 21:32:13 +0800
From: "pang.xunlei" <pang.xunlei@...aro.org>
To: Steven Rostedt <rostedt@...dmis.org>
Cc: lkml <linux-kernel@...r.kernel.org>,
Peter Zijlstra <peterz@...radead.org>,
Juri Lelli <juri.lelli@...il.com>
Subject: Re: [PATCH 1/2] sched/deadline: Modify cpudl.free_cpus to reflect rd->span
On 18 November 2014 03:39, Steven Rostedt <rostedt@...dmis.org> wrote:
> On Tue, 18 Nov 2014 00:11:03 +0800
>
>> index 539ca3c..9a69353
>> --- a/kernel/sched/cpudeadline.c
>> +++ b/kernel/sched/cpudeadline.c
>> @@ -107,7 +107,9 @@ int cpudl_find(struct cpudl *cp, struct task_struct *p,
>> int best_cpu = -1;
>> const struct sched_dl_entity *dl_se = &p->dl;
>>
>> - if (later_mask && cpumask_and(later_mask, later_mask, cp->free_cpus)) {
>> + if (later_mask && cpumask_and(later_mask, cp->free_cpus,
>> + &p->cpus_allowed) && cpumask_and(later_mask,
>> + later_mask, cpu_active_mask)) {
>
> I did a quick review of this patch, and it looks fine to me. But the
> above looks ugly. Please change it to something more readable like:
Yes, the following looks beautiful. I'll adjust it, thanks!
>
> if (later_mask &&
> cpumask_and(later_mask, cp->free_cpus, &p->cpus_allowed) &&
> cpumask_and(later_mask, later_mask, cpu_active_mask)) {
>
> Thanks,
>
> -- Steve
>
>
>> best_cpu = cpumask_any(later_mask);
>> goto out;
>> } else if (cpumask_test_cpu(cpudl_maximum(cp), &p->cpus_allowed) &&
>> @@ -186,6 +188,17 @@ out:
>> }
>>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists