[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CACRpkdbd2cAD5osYnwKTg4d1MwSjNF9i3Y+6ryjc_qLsg46Wtg@mail.gmail.com>
Date: Tue, 2 Dec 2014 16:01:35 +0100
From: Linus Walleij <linus.walleij@...aro.org>
To: Soren Brinkmann <soren.brinkmann@...inx.com>
Cc: Michal Simek <michal.simek@...inx.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
Alessandro Rubini <rubini@...pv.it>,
Heiko Stuebner <heiko@...ech.de>,
Laurent Pinchart <laurent.pinchart@...asonboard.com>,
"open list:ARM/Rockchip SoC..." <linux-rockchip@...ts.infradead.org>,
"linux-sh@...r.kernel.org" <linux-sh@...r.kernel.org>,
"Ivan T. Ivanov" <iivanov@...sol.com>,
Bjorn Andersson <bjorn.andersson@...ymobile.com>,
Beniamino Galvani <b.galvani@...il.com>
Subject: Re: [PATCH v2 1/7] pinctrl: pinconf-generic: Infer map type from DT property
On Fri, Nov 28, 2014 at 2:26 AM, Soren Brinkmann
<soren.brinkmann@...inx.com> wrote:
> With the new 'groups' property, the DT parser can infer the map type
> from the fact whether 'pins' or 'groups' is used to specify the pin
> group to work on.
> To maintain backwards compatibitliy with current usage of the DT
> binding, this is only done when an invalid map type is passed to the
> parsing function.
>
> Signed-off-by: Soren Brinkmann <soren.brinkmann@...inx.com>
> Tested-by: Andreas Färber <afaerber@...e.de>
> ---
> Changes since RFC v2:
> - none
OK there are problems with this.
> @@ -264,6 +264,7 @@ int pinconf_generic_dt_subnode_to_map(struct pinctrl_dev *pctldev,
> unsigned reserve;
> struct property *prop;
> const char *group;
> + const char *dt_pin_specifier = "pins";
Something called "dt_pin_specifier" contains the string "pins"...
>
> ret = of_property_read_string(np, "function", &function);
> if (ret < 0) {
> @@ -284,10 +285,20 @@ int pinconf_generic_dt_subnode_to_map(struct pinctrl_dev *pctldev,
> reserve++;
> if (num_configs)
> reserve++;
> +
> ret = of_property_count_strings(np, "pins");
> if (ret < 0) {
> - dev_err(dev, "could not parse property pins\n");
> - goto exit;
> + ret = of_property_count_strings(np, "groups");
> + if (ret < 0) {
> + dev_err(dev, "could not parse property pins/groups\n");
> + goto exit;
> + }
> + if (type == PIN_MAP_TYPE_INVALID)
> + type = PIN_MAP_TYPE_CONFIGS_GROUP;
> + dt_pin_specifier = "groups";
Then suddenly "groups".
The pointer variable should be named something like "subnode_target_type"
or so.
> +++ b/include/linux/pinctrl/pinconf-generic.h
> @@ -174,6 +174,13 @@ static inline int pinconf_generic_dt_node_to_map_pin(
> PIN_MAP_TYPE_CONFIGS_PIN);
> }
>
> +static inline int pinconf_generic_dt_node_to_map_all(
> + struct pinctrl_dev *pctldev, struct device_node *np_config,
> + struct pinctrl_map **map, unsigned *num_maps)
> +{
> + return pinconf_generic_dt_node_to_map(pctldev, np_config, map, num_maps,
> + PIN_MAP_TYPE_INVALID);
> +}
First add some comment describing what happens here and why
INVALID is specified.
Then what does this have to do with the $subject?
Atleast mention in the commit text that a new helper is added, though unused.
Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists