[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1822504.xkcBG8sz41@wuerfel>
Date: Thu, 18 Dec 2014 10:12:33 +0100
From: Arnd Bergmann <arnd@...db.de>
To: Matthias Brugger <matthias.bgg@...il.com>
Cc: Eddie Huang <eddie.huang@...iatek.com>,
Mark Rutland <mark.rutland@....com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
srv_heupstream <srv_heupstream@...iatek.com>,
Rob Herring <robh+dt@...nel.org>,
Pawel Moll <pawel.moll@....com>,
Ian Campbell <ijc+devicetree@...lion.org.uk>,
Kumar Gala <galak@...eaurora.org>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will.deacon@....com>, Jiri Slaby <jslaby@...e.cz>,
Alan Cox <alan@...ux.intel.com>,
"devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
linux-serial@...r.kernel.org, Sascha Hauer <kernel@...gutronix.de>,
Yingjoe Chen <yingjoe.chen@...iatek.com>,
YH Chen (陳昱豪) <yh.chen@...iatek.com>
Subject: Re: [PATCH 1/2] tty: serial: 8250_mtk: Add earlycon
On Thursday 18 December 2014 09:48:31 Matthias Brugger wrote:
> > +static void __init mtk8250_serial_putc(struct uart_port *port, int c)
> > +{
> > + while ((readl(port->membase + (UART_LSR << 2)) & BOTH_EMPTY) !=
> > + BOTH_EMPTY)
> > + ;
>
> Please delete newline before the semicolon.
>
No, that newline is best kept in there for clarity. An even better way
to write this would be using cpu_relax():
while ((readl(port->membase + (UART_LSR << 2)) & BOTH_EMPTY) != BOTH_EMPTY)
cpu_relax();
which the kernel convention for doing busy-loops.
Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists