lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 25 Dec 2014 10:30:46 +0800
From:	Peter Chen <peter.chen@...escale.com>
To:	Stefan Agner <stefan@...er.ch>
CC:	Sanchayan Maity <maitysanchayan@...il.com>,
	<gregkh@...uxfoundation.org>, <linux-usb@...r.kernel.org>,
	<linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 2/3] usb: chipidea: Add chipidea revision information

On Wed, Dec 24, 2014 at 05:22:44PM +0100, Stefan Agner wrote:
> On 2014-12-19 10:55, Sanchayan Maity wrote:
> > Define ci_get_revision API to know the controller revision
> > information according to chipidea 1.1a, 2.0a, 2.4 and 2.5a
> > spec. Besides, add one entry in struct ci_hdrc to indicate
> > revision information. This can be used for adding different
> > code for revisions, implementing erratas.
> > 
> > Signed-off-by: Sanchayan Maity <maitysanchayan@...il.com>
> > ---
> >  drivers/usb/chipidea/bits.h |   10 ++++++++++
> >  drivers/usb/chipidea/core.c |   23 +++++++++++++++++++++--
> >  2 files changed, 31 insertions(+), 2 deletions(-)
> > 
> > diff --git a/drivers/usb/chipidea/bits.h b/drivers/usb/chipidea/bits.h
> > index ca57e3d..e935ccc 100644
> > --- a/drivers/usb/chipidea/bits.h
> > +++ b/drivers/usb/chipidea/bits.h
> > @@ -15,6 +15,16 @@
> >  
> >  #include <linux/usb/ehci_def.h>
> >  
> > +/*
> > + * ID
> > + * For 1.x revision, bit24 - bit31 are reserved
> > + * For 2.x revision, bit25 - bit28 are 0x2
> > + */
> > +#define TAG			(0x1F << 16)
> > +#define REVISION		(0xF << 21)
> > +#define VERSION			(0xF << 25)
> > +#define CIVERSION		(0x7 << 29)
> > +
> 
> Hm, the other defines use spaces in this file, I like tabs more too, but
> I guess uniformity wins here.. Peter?

I will change to use spaces.

> 
> >  /* HCCPARAMS */
> >  #define HCCPARAMS_LEN         BIT(17)
> >  
> > diff --git a/drivers/usb/chipidea/core.c b/drivers/usb/chipidea/core.c
> > index 9bdc6bd..33a8c4a 100644
> > --- a/drivers/usb/chipidea/core.c
> > +++ b/drivers/usb/chipidea/core.c
> > @@ -136,6 +136,22 @@ static int hw_alloc_regmap(struct ci_hdrc *ci, bool is_lpm)
> >  	return 0;
> >  }
> >  
> > +static enum CI_REVISION ci_get_revision(struct ci_hdrc *ci)
> > +{
> > +	int ver = hw_read_id_reg(ci, ID_ID, VERSION) >> __ffs(VERSION);
> > +	enum CI_REVISION rev = CI_REVISION_UNKNOWN;
> > +
> > +	if (ver == 0x2) {
> > +		int rev_reg = hw_read_id_reg
> > +			(ci, ID_ID, REVISION) >> __ffs(REVISION);
> 
> This line break is somewhat awkward, doesn't help for good readability.
> 

But it exceeds 80 characters, maybe I change like below:

 		rev += hw_read_id_reg(ci, ID_ID, REVISION)
	       		>> __ffs(REVISION);
> Is the local integer variable necessary at all? Enums are arithmetic
> types, so afaik this should be fine too:
> 		rev = CI_REVISION_20;
> 		rev += hw_read_id_reg(ci, ID_ID, REVISION) >> __ffs(REVISION);

Will change, thanks.

-- 

Best Regards,
Peter Chen
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ