lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 02 Jan 2015 17:04:42 +0100
From:	Michal Marek <mmarek@...e.cz>
To:	Masahiro Yamada <yamada.m@...panasonic.com>,
	linux-kbuild@...r.kernel.org
CC:	linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules

On 2014-12-24 07:49, Masahiro Yamada wrote:
> The rules "cmd_bounds" and "cmd_offsets" are almost the same.
> (The difference is only the include guards.)  They can be merged.

Good idea.


> Signed-off-by: Masahiro Yamada <yamada.m@...panasonic.com>
> ---
> 
>  Kbuild | 59 +++++++++++++++++++++--------------------------------------
>  1 file changed, 21 insertions(+), 38 deletions(-)
> 
> diff --git a/Kbuild b/Kbuild
> index 5d7c729..55a639f 100644
> --- a/Kbuild
> +++ b/Kbuild
> @@ -5,19 +5,20 @@
>  # 2) Generate asm-offsets.h (may need bounds.h)
>  # 3) Check for missing system calls
>  
> -#####
> -# 1) Generate bounds.h
> -
> -bounds-file := include/generated/bounds.h
> -
> -always  := $(bounds-file)
> -targets := $(bounds-file) kernel/bounds.s
> +# Default sed regexp - multiline due to syntax constraints
> +define sed-y
> +	"/^->/{s:->#\(.*\):/* \1 */:; \
> +	s:^->\([^ ]*\) [\$$#]*\([-0-9]*\) \(.*\):#define \1 \2 /* \3 */:; \
> +	s:^->\([^ ]*\) [\$$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; \
> +	s:->::; p;}"
> +endef
>  
> -quiet_cmd_bounds = GEN     $@
> -define cmd_bounds
> +quiet_cmd_offsets = GEN     $@
> +define cmd_offsets
>  	(set -e; \
> -	 echo "#ifndef __LINUX_BOUNDS_H__"; \
> -	 echo "#define __LINUX_BOUNDS_H__"; \
> +	 INCLUDE_GUARD=$$(echo __$(notdir $@)__ | tr '[a-z].-' '[A-Z]__'); \
> +	 echo "#ifndef $$INCLUDE_GUARD"; \
> +	 echo "#define $$INCLUDE_GUARD"; \

I think it would be more readable to write it as

  echo "#ifndef $(2)"; \
  ...

and pass the include guard name as an argument to cmd_offsets.

Otherwise it's a great cleanup.

Michal
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ