lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 6 Jan 2015 19:27:49 +0100
From:	Sam Ravnborg <sam@...nborg.org>
To:	"Michael S. Tsirkin" <mst@...hat.com>
Cc:	linux-kernel@...r.kernel.org, Arnd Bergmann <arnd@...db.de>,
	linux-arch@...r.kernel.org,
	"David S. Miller" <davem@...emloft.net>, sparclinux@...r.kernel.org
Subject: Re: [PATCH v2 26/40] arch/sparc: uaccess_64 macro whitespace fixes

On Tue, Jan 06, 2015 at 07:19:02PM +0200, Michael S. Tsirkin wrote:
> On Tue, Jan 06, 2015 at 05:53:39PM +0100, Sam Ravnborg wrote:
> > On Tue, Jan 06, 2015 at 05:44:56PM +0200, Michael S. Tsirkin wrote:
> > > Macros within arch/sparc/include/asm/uaccess_64.h are made harder to
> > > read because they violate a bunch of coding style rules.
> > > 
> > > Fix it up.
> > As per Davem's earlier mail please prefix using sparc32/sparc64.
> 
> I did put in uaccess_64 - insufficient?
sparc32: bla bla
For sparc32 specific changes.

sparc64: bla bla
For sparc64 specific changes

sparc: bla bla
For general sparce changes


In this case you could have used:
sparc64: fix coding style in uaccess_64.h

> 
> > > -#define __put_user_nocheck(data,addr,size) ({ \
> > > -register int __pu_ret; \
> > > -switch (size) { \
> > > -case 1: __put_user_asm(data,b,addr,__pu_ret); break; \
> > > -case 2: __put_user_asm(data,h,addr,__pu_ret); break; \
> > > -case 4: __put_user_asm(data,w,addr,__pu_ret); break; \
> > > -case 8: __put_user_asm(data,x,addr,__pu_ret); break; \
> > > -default: __pu_ret = __put_user_bad(); break; \
> > > -} __pu_ret; })
> > > -
> > > -#define __put_user_asm(x,size,addr,ret)					\
> > > +#define __put_user_nocheck(data, addr, size) ({ \
> > > +	register int __pu_ret; \
> > > +	switch (size) { \
> > > +	case 1: \
> > > +		__put_user_asm(data, b, addr, __pu_ret); \
> > > +		break; \
> > > +	case 2: \
> > > +		__put_user_asm(data, h, addr, __pu_ret); \
> > > +		break; \
> > > +	case 4: \
> > > +		__put_user_asm(data, w, addr, __pu_ret); \
> > > +		break; \
> > > +	case 8: \
> > > +		__put_user_asm(data, x, addr, __pu_ret); \
> > > +		break; \
> > > +	default: \
> > > +		__pu_ret = __put_user_bad(); \
> > > +		break; \
> > > +	} \
> > > +	__pu_ret; \
> > > +})
> > 
> > No matter what coding style says - the above is much less readable than the
> > original version.
> > 
> > 
> I guess you approve the rest of the changes then?
I did not look to carefully - but what I saw looked good.

> 
> 
> I get it you like it that 
> 	case 1: __get_user_asm(__gu_val,ub,addr,__gu_ret); break;
> has the whole case on the same line?
> Is that the issue?
Exactly - much easier to read this way.
That the "\" was not aligned in these parts of the code did not help either.

	Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ