[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1421686573-12771-1-git-send-email-vkuznets@redhat.com>
Date: Mon, 19 Jan 2015 17:56:10 +0100
From: Vitaly Kuznetsov <vkuznets@...hat.com>
To: "K. Y. Srinivasan" <kys@...rosoft.com>,
devel@...uxdriverproject.org
Cc: Haiyang Zhang <haiyangz@...rosoft.com>,
linux-kernel@...r.kernel.org, Dexuan Cui <decui@...rosoft.com>,
Jason Wang <jasowang@...hat.com>,
Radim Krčmář <rkrcmar@...hat.com>
Subject: [PATCH v2 0/3] Drivers: hv: vmbus: protect Offer/Rescind offer processing
This patch series is a successor of "[PATCH] Drivers: hv: vmbus: serialize
Offer and Rescind offer processing" and thereby have 'v2' in its name.
Changes from v1:
- Separate vmbus_device_create() return value check [K. Y. Srinivasan]
- Do not lose a rescind offer received during offer processing. Use renamed
(in [PATCH v2 2/3]) spinlock to protect simulteneous test-and-set workflow for
rescind and work fields. [K. Y. Srinivasan]
Vitaly Kuznetsov (3):
Drivers: hv: check vmbus_device_create() return value in
vmbus_process_offer()
Drivers: hv: rename sc_lock to the more generic lock
Drivers: hv: vmbus: serialize Offer and Rescind offer
drivers/hv/channel.c | 6 +++---
drivers/hv/channel_mgmt.c | 45 ++++++++++++++++++++++++++++++++-------------
include/linux/hyperv.h | 7 ++++++-
3 files changed, 41 insertions(+), 17 deletions(-)
--
1.9.3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists