[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20150129151332.3f87c0b2e335afd88af33e08@linux-foundation.org>
Date: Thu, 29 Jan 2015 15:13:32 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Andrey Ryabinin <a.ryabinin@...sung.com>
Cc: linux-kernel@...r.kernel.org, Dmitry Vyukov <dvyukov@...gle.com>,
Konstantin Serebryany <kcc@...gle.com>,
Dmitry Chernenkov <dmitryc@...gle.com>,
Andrey Konovalov <adech.fo@...il.com>,
Yuri Gribov <tetra2005@...il.com>,
Konstantin Khlebnikov <koct9i@...il.com>,
Sasha Levin <sasha.levin@...cle.com>,
Christoph Lameter <cl@...ux.com>,
Joonsoo Kim <iamjoonsoo.kim@....com>,
Dave Hansen <dave.hansen@...el.com>,
Andi Kleen <andi@...stfloor.org>, x86@...nel.org,
linux-mm@...ck.org, Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>,
Rusty Russell <rusty@...tcorp.com.au>,
Michal Marek <mmarek@...e.cz>,
linux-kbuild@...r.kernel.org (open list:KERNEL BUILD + fi...)
Subject: Re: [PATCH v10 17/17] kasan: enable instrumentation of global
variables
On Thu, 29 Jan 2015 18:12:01 +0300 Andrey Ryabinin <a.ryabinin@...sung.com> wrote:
> This feature let us to detect accesses out of bounds
> of global variables.
global variables *within modules*, I think? More specificity needed here.
> The idea of this is simple. Compiler increases each global variable
> by redzone size and add constructors invoking __asan_register_globals()
> function. Information about global variable (address, size,
> size with redzone ...) passed to __asan_register_globals() so we could
> poison variable's redzone.
>
> This patch also forces module_alloc() to return 8*PAGE_SIZE aligned
> address making shadow memory handling ( kasan_module_alloc()/kasan_module_free() )
> more simple. Such alignment guarantees that each shadow page backing
> modules address space correspond to only one module_alloc() allocation.
>
> ...
>
> +int kasan_module_alloc(void *addr, size_t size)
> +{
> +
> + size_t shadow_size = round_up(size >> KASAN_SHADOW_SCALE_SHIFT,
> + PAGE_SIZE);
> + unsigned long shadow_start = kasan_mem_to_shadow((unsigned long)addr);
> + void *ret;
Like this:
size_t shadow_size;
unsigned long shadow_start;
void *ret;
shadow_size = round_up(size >> KASAN_SHADOW_SCALE_SHIFT, PAGE_SIZE);
shadow_start = kasan_mem_to_shadow((unsigned long)addr);
it's much easier to read and avoids the 80-column trickery.
I do suspect that
void *kasan_mem_to_shadow(const void *addr);
would clean up lots and lots of code.
> + if (WARN_ON(!PAGE_ALIGNED(shadow_start)))
> + return -EINVAL;
> +
> + ret = __vmalloc_node_range(shadow_size, 1, shadow_start,
> + shadow_start + shadow_size,
> + GFP_KERNEL | __GFP_HIGHMEM | __GFP_ZERO,
> + PAGE_KERNEL, VM_NO_GUARD, NUMA_NO_NODE,
> + __builtin_return_address(0));
> + return ret ? 0 : -ENOMEM;
> +}
> +
>
> ...
>
> +struct kasan_global {
> + const void *beg; /* Address of the beginning of the global variable. */
> + size_t size; /* Size of the global variable. */
> + size_t size_with_redzone; /* Size of the variable + size of the red zone. 32 bytes aligned */
> + const void *name;
> + const void *module_name; /* Name of the module where the global variable is declared. */
> + unsigned long has_dynamic_init; /* This needed for C++ */
This can be removed?
> +#if KASAN_ABI_VERSION >= 4
> + struct kasan_source_location *location;
> +#endif
> +};
>
> ...
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists