[<prev] [next>] [day] [month] [year] [list]
Message-Id: <1422702607-27762-1-git-send-email-der.herr@hofr.at>
Date: Sat, 31 Jan 2015 12:10:07 +0100
From: Nicholas Mc Guire <der.herr@...r.at>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: navin patidar <navin.patidar@...il.com>,
Larry Finger <Larry.Finger@...inger.net>,
Jia He <hejianet@...il.com>, devel@...verdev.osuosl.org,
linux-kernel@...r.kernel.org, Nicholas Mc Guire <der.herr@...r.at>
Subject: [PATCH] staging: rtl8188eu: use msecs_to_jiffies for conversions
This is only an API consolidation to make things more readable.
Instances of var * HZ / 1000 are replaced by msecs_to_jiffies(var).
Signed-off-by: Nicholas Mc Guire <der.herr@...r.at>
---
Converting milliseconds to jiffies by "val * HZ / 1000" is technically
ok but msecs_to_jiffies(val) is the cleaner solution and handles all
corner cases correctly. This is a minor API cleanup only.
This patch was only compile tested with x86_64_defconfig + CONFIG_STAGING=y
CONFIG_R8188EU=m
Patch is against 3.19.0-rc6 -next-20150129
drivers/staging/rtl8188eu/include/osdep_service.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/include/osdep_service.h b/drivers/staging/rtl8188eu/include/osdep_service.h
index 82f58f8..3a27477 100644
--- a/drivers/staging/rtl8188eu/include/osdep_service.h
+++ b/drivers/staging/rtl8188eu/include/osdep_service.h
@@ -87,7 +87,7 @@ static inline void _init_timer(struct timer_list *ptimer,
static inline void _set_timer(struct timer_list *ptimer, u32 delay_time)
{
- mod_timer(ptimer , (jiffies+(delay_time*HZ/1000)));
+ mod_timer(ptimer , (jiffies+msecs_to_jiffies(delay_time)));
}
#define RTW_TIMER_HDL_ARGS void *FunctionContext
--
1.7.10.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists