lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <159DFFC6-C7C3-4A11-9612-595984C9F4C3@intel.com>
Date:	Thu, 5 Feb 2015 22:28:16 +0000
From:	"Drokin, Oleg" <oleg.drokin@...el.com>
To:	Tal Shorer <tal.shorer@...il.com>
CC:	"<linux-kernel@...r.kernel.org>" <linux-kernel@...r.kernel.org>,
	"Dilger, Andreas" <andreas.dilger@...el.com>,
	"<gregkh@...uxfoundation.org>" <gregkh@...uxfoundation.org>,
	"<dan.carpenter@...cle.com>" <dan.carpenter@...cle.com>,
	"<luca@...aceresoli.net>" <luca@...aceresoli.net>,
	"<clabbe.montjoie@...il.com>" <clabbe.montjoie@...il.com>,
	"<PDD-discuss@...ts.01.org>" <PDD-discuss@...ts.01.org>,
	"<devel@...verdev.osuosl.org>" <devel@...verdev.osuosl.org>
Subject: Re: [PATCH] staging: lustre: fix coding style errors in
 drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c


On Feb 5, 2015, at 5:07 PM, Tal Shorer wrote:

> Signed-off-by: Tal Shorer <tal.shorer@...il.com>
> ---
> drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c b/drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c
> index c539e37..acc2e10 100644
> --- a/drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c
> +++ b/drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c
> @@ -65,7 +65,7 @@
> #include <asm/div64.h>
> #include "../tracefile.h"
> 
> -static struct ctl_table_header *lnet_table_header = NULL;
> +static struct ctl_table_header *lnet_table_header;
> extern char lnet_upcall[1024];
> /**
>  * The path of debug log dump upcall script.
> @@ -165,7 +165,7 @@ static int proc_dobitmasks(struct ctl_table *table, int write,
> 				 __proc_dobitmasks);
> }
> 
> -static int min_watchdog_ratelimit = 0;	  /* disable ratelimiting */
> +static int min_watchdog_ratelimit;	  /* disable ratelimiting */

I think you just made this comment nonsensical by this change.
= 0 is explained as that disables the rate limiting. With no assignment (I know it's a noop)
it's now unclear what does the comment says and possibly needs to be expanded to
say something like "0 to disable ratelimiting" or the like, but it's less readable.

> static int max_watchdog_ratelimit = (24*60*60); /* limit to once per day */

In reality these two "variables" are nothing more than constants, they are never changed too.
Their only purpose is to be fed into procfs code (proc_dointvec_minmax) to know the range
of values to accepted.
As such spelling them out makes the most sense in my view.

The rest of the patch I think is good.
Thanks.

> static int __proc_dump_kernel(void *data, int write,
> @@ -308,7 +308,7 @@ static int proc_console_backoff(struct ctl_table *table, int write,
> 	dummy.proc_handler = &proc_dointvec;
> 
> 	if (!write) { /* read */
> -		backoff= libcfs_console_backoff;
> +		backoff = libcfs_console_backoff;
> 		rc = proc_dointvec(&dummy, write, buffer, lenp, ppos);
> 		return rc;
> 	}
> -- 
> 2.2.2
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ