lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 9 Feb 2015 11:10:12 +0100
From:	Bas Peters <baspeters93@...il.com>
To:	Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
Cc:	gregkh@...uxgoundation.org, Alan Stern <stern@...land.harvard.edu>,
	dan.j.williams@...el.com, hdegoede@...hat.com,
	sarah.a.sharp@...ux.intel.com,
	Peter Chen <peter.chen@...escale.com>,
	linux-usb@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/6] drivers: usb: core: hcd.c: remove assignment of
 variables in if conditions.

2015-02-08 12:15 GMT+01:00 Sergei Shtylyov <sergei.shtylyov@...entembedded.com>:
> Hello.
>
> On 2/8/2015 12:55 AM, Bas Peters wrote:
>
>> This patch removes assignment of variables in if conditions,
>> as specified in CodingStyle.
>
>
>> Signed-off-by: Bas Peters <baspeters93@...il.com>
>> ---
>>   drivers/usb/core/hcd.c | 15 ++++++++++-----
>>   1 file changed, 10 insertions(+), 5 deletions(-)
>
>
>> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
>> index 11cee55..37c40d1 100644
>> --- a/drivers/usb/core/hcd.c
>> +++ b/drivers/usb/core/hcd.c
>
> [...]
>>
>> @@ -2733,7 +2736,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
>>         /* "reset" is misnamed; its role is now one-time init. the
>> controller
>>          * should already have been reset (and boot firmware kicked off
>> etc).
>>          */
>> -       if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0)
>> {
>> +       retval = hcd->driver->reset(hcd);
>
>
>    This will crash if 'hcd->driver->reset' is NULL (which is only checked
> below).
>
>> +       if (hcd->driver->reset && retval < 0) {
>
>
>    It wasn't equivalent change anyway as the right part of && is only
> executed if the left part is true.

I'll fix this and your other comments and resend.

>
> WBR, Sergei
>

With kind regards,

Bas
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ