[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <54DCB703.9020109@linux.vnet.ibm.com>
Date: Thu, 12 Feb 2015 19:51:55 +0530
From: Raghavendra K T <raghavendra.kt@...ux.vnet.ibm.com>
To: Oleg Nesterov <oleg@...hat.com>
CC: tglx@...utronix.de, mingo@...hat.com, hpa@...or.com,
peterz@...radead.org, torvalds@...ux-foundation.org,
konrad.wilk@...cle.com, pbonzini@...hat.com,
paulmck@...ux.vnet.ibm.com, waiman.long@...com, davej@...hat.com,
x86@...nel.org, jeremy@...p.org, paul.gortmaker@...driver.com,
ak@...ux.intel.com, jasowang@...hat.com,
linux-kernel@...r.kernel.org, kvm@...r.kernel.org,
virtualization@...ts.linux-foundation.org,
xen-devel@...ts.xenproject.org, riel@...hat.com,
borntraeger@...ibm.com, akpm@...ux-foundation.org,
a.ryabinin@...sung.com, sasha.levin@...cle.com, dave@...olabs.net
Subject: Re: [PATCH V3] x86 spinlock: Fix memory corruption on completing
completions
On 02/12/2015 07:07 PM, Oleg Nesterov wrote:
> On 02/12, Raghavendra K T wrote:
>>
>> @@ -772,7 +773,8 @@ __visible void kvm_lock_spinning(struct arch_spinlock *lock, __ticket_t want)
>> * check again make sure it didn't become free while
>> * we weren't looking.
>> */
>> - if (ACCESS_ONCE(lock->tickets.head) == want) {
>> + head = ACCESS_ONCE(lock->tickets.head);
>> + if (__tickets_equal(head, want)) {
>> add_stats(TAKEN_SLOW_PICKUP, 1);
>
> While at it, perhaps it makes sense to s/ACCESS_ONCE/READ_ONCE/ but this
> is cosmetic.
yes.. will do.
>
> We also need to change another user of enter_slow_path, xen_lock_spinning()
> in arch/x86/xen/spinlock.c.
>
Had in mind but forgot before sending. will update resend.
> Other than that looks correct at first glance... but this is up to
> maintainers.
>
Thanks
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists